RTF Template

Can I setup a template for the blank RTF document that is created by a Rich Text button or Data>New>Rich Text? Basically to setup a new default ruler with style, tabs, spacing, etc.

I did try by creating a blank document and saving it with File>Export>as Template… . But new documents with either the Rich Text button or Data>New>With Template remain the same using the standard defaults as before.

Put some content into the rich text document, set up your desired ruler settings, etc. Now export it as a Template. When you use that template, substitute your new content for the “dummy” content.

That’s exactly how I expected it to work, but it doesn’t. The created template is there in Data>New>With Template but a document still has the standard defaults and not the template’s.

Also, I would like to have the new default template used from the Rich Text button in the toolbar without having to go to Data>New>With Template each time.

Am I the only one unable to create and use a default template or is this a bug?

A new RTF document created with Data>New>With Template shows up with “RTF Template-1” as its name. The exported template was named “RTF Template”. But its contents (ruler, font, spacing, etc.) are the original defaults and not those of the template.

Original defaults are those you get using the Rich Text toolbar button.

Changing the ruler doesn’t mark the document as modified, therefore adapt the ruler, add & remove a character and save the document.

Not happening.

New Rich Text document. Make ruler, type, and spacing changes. Add a heading of fixed text. Save the RTF. File > Export > as Template… name “RTF Template”.

Data > New > With Template > RTF Template. Result is a “RTF Template-1” entry with none of the changes made in the template.

I’ve got two RTF templates that use non-default font, font size and ruler settings. One of them is a Cornell Notes template.

To create a new Template, I put in some “place holder” text, then name and save it and export as Template.

When I select one of those templates, the new RTF document has the settings I established for the template’s font, font size and ruler settings. In the case of my Cornell Notes template, a table is included.

To use the new document based on a template, I select “place holder” text and start typing. Works perfectly.

I did create a workable template. I’m sorry I do not have the time to thoroughly troubleshoot what is happening, but now I do have a good idea why I could not create a workable template before.

It is a difference in what is probably expected, but I am not doing.

Either, I had created the template using the same name as a previous template, acknowledged the “already exists” dialog, but then the revised template was not saved.

Or, I had created the template using the 3-pane view in the Inbox, not a Group, and then never opened and saved the document before exporting it. Maybe exporting it only from a highlighted entry Name and not from an opened document.

In the end my workable template is one with a new name that did not replace a previous template.

Are Styles across-the-board for all RTF documents and not related to any template? While added Spacing setups are related to a template?

And, I did notice an odd behavior:

  1. Create a new RTF in the 3-pane view, the entry is highlighted and its Name is ready to be edited.

  2. Click in the text area and there is a slight shift of the ruler margins and tab stops.

  3. Click back on the entry name and the ruler stays at these revised margins and tab stops.

  4. Click back in the text area and the ruler stays at these revised margins and tab stops.

  5. Click on a different entry, then click back on the name of the new RTF and the ruler is back to its original values.

  6. Click back in the text area and this pattern of the revised ruler repeats.

This ruler shift behavior may be related to my playing around with templates, but still something is amiss with these unexpected shifts.

Finally, how do I get rid of superfluous templates?

The template documents are stored at ~/Library/Application Support/DEVONthink Pro 2/Templates.noindex/. Just delete the ones you no longer want to keep.