Safari Extension has disappeared

I recently upgraded to the latest version. I am using Office Pro. My web extension has disappeared.

I have tried emptying the cash, rebooting, removing all of my other extensions from Safari, and attempting to install the Safari extension from the main menu, Install Add-ons. Yet, I am no longer able to clip the data directly direct Devon Think. when I tried to reinstall the extensions I only get the “Doink” error sound. and no extensions appear in my browser .

I would very much appreciate suggestions on how to get my extension back. I know that you will be able to easily and naturally solve my problem and put me back on the road to learning DevonThink.

Thanks much,
David Lisko

Did you already try to install the extension via the Safari Extensions gallery?

I just went to the Safari Extension Gallery … clicked on the “Clip to DEVONThink” link … it took me to the DT page where the only browser extensions shown are Firefox and Chrome.

So I’m using the bookmarklet, but does this mean there’s no more Safari extension?

The extension is hosted here: … 679S2QUWR8

but it requires El Capitan to install from here. If you’re using an earlier OS, you can install from the DEVONthink menu item > Install Add-Ons…

It’s not working. I am running El Capitan (10.11.1).

When I click on your link, it takes me to the Safari extension page for “Clip to DEVONThink”.

When I click on that link it takes me to … nuals.html, where there is no Safari extension shown.

Try emptying your cache. I just uninstalled and now reinstalled the Safari extension from that link.

I emptied the cache, quit Safari, re-opened it … same problem. Apple site leads me to DT page with only Firefox and Chrome extensions available.

Try … 679S2QUWR8

Thanks, but that is the URL I’ve been trying.

Don’t click the “DEVONtechnologies” link on that Apple page. Click the “Install Now” link. If the page says “Installed” instead of “Install Now” then go to Safari Preferences, remove the extension, refresh the Apple page, and reinstall.

I do not get an “Install Now” button. And it doesn’t say “Installed”.
Screen Shot 2015-12-08 at 11.05.50 AM.png

Contrary to Jim’s post above, the site doesn’t require El Capitan (Yosemite works fine), but it does require Safari 9. Are you running AdBlock or some other privacy tool(s)?

Did you try Jim’s other advice: open DEVONthink > Install Add Ons… and install from DEVONthink directly?

Or just open the DEVONthink application package (select it in Applications and use Show Package Contents from the contextual menu) and browse to /Applications/DEVONthink and double-click Clip to DEVONthink.safariextz

I was using the latest OS X and Safari, and had disabled AdBlock. But your final suggestion (double-click Clip to DEVONthink.safariextz) solved the problem.

I first chose “Install from Gallery” and nothing happened. So I went back and chose “Install from Developer”, and it installed.

Anyway, it’s up and running, and I thank you for your patience and guidance.

I did a fresh install of DEVONthink on a new retina display Macbook and since then was not able to get the clip to DEVONthink extension in Safari to work. I have followed the suggestions on this thread but to no avail. A greyed out clip icon appears in Safari but it is not working as before (on my old Macbook).

Any further suggestions on how to fix this?

Thank you and best regards

If the icon appears, it is installed.
If it’s greyed out, it means there’s nothing to clip. This can be shown on Google’s landing page.

Thanks for the reply.

Previously the Safari clip icon was blue and when clicked on, a dialogue box opened prompting the user how the website should be clipped (archive, html, pdf etc). Currently, when I click on the grey icon (I have seen that the icon fades even to a lighter grey on e.g. Google home page) nothing happens (not even when I select text on a website).

Is there perhaps a setting that I missed with the new install?


It started working a few seconds after my previous reply. (For no apparent reason that I could figure (did not change anything)).


Nope. There’s nothing much to configure, but I’m glad to hear it’s working.