"SaveClip" Not working with Mailpalne DT3

Just got an update for Mailplane 4.1.4 that we can ‘save clip’ to DT3. :smiley:

  1. So I downloaded the DT3 > went to Mac Preferences > Extensions > “Share Menu” > uncheck “add to DevonThink” checked "Add to DEVONthink 3.
    2 Went to Mailplane, selected an email > File > Save Clip > selected “DevonThink”
  2. DT3 app opened up, but nothing was saved.

I contacted Mailplane they said it worked fine on their side. I sent them a link to my dropbox showing a screencast of the above steps. Waiting for their reply.
In the meantime thought I see if any of you good folks might have some suggestions.

Other actions taken:
I’ve restarted Mailplane. Closed both apps and relaunched. Restarted my computer. No luck.
Macmini late 2012 macOS 10.14.6

Can you provide the link to the screencast you sent them?

Sorry, I forgot to add that. Apologies.
Here’s the the screencast link:

Please note. I just got out of the hospital and my mind is a little bit slow after the surgery. The VDO clearly shows me:

Selecting an email
Selecting “Clip Save”
Selecting "DevonThink
DT3 opens up to a “blank window” – the email was not clipped.

No worries and I hope you’re on the mend!

I’m not sure of what mechanism Mailplane uses for this but does it have Full Disk Access (may not be required, but may…) and Automation requests enabled in System Preferences > Security & Privacy > Security?

Thank you for your reply.
I added Mailplane to Privacy still didn’t work.
I wouldn’t be surprised if it’s something simple. I’m going to make another
screencast for Mailplane and be more specific about how it’s set up, number of tabs, etc.
Thank you again for your suggestion. It may come in handy in the future when troubleshooting another app.

You’re welcome :slight_smile:

I looked inside the application and didn’t see any specific asset for this purpose, so yeah Mailplane would have to respond on it. Cheers!

1 Like

Partial Success!
I updated to Mailplane’s Beta: 4.1.5 Preview
Result: I could clip-save an email.
New Problem:
Even though I could now clip-save an email, clip-save would not save the “whole thread” only the first message of the thread.
Temporary Solution:
Mailplane support told me this was a bug they’re working on. The workaround was to
go to “no split” view. I always used “vertical split”.

For now. All is good.

Thanks for the follow-up!