Scanner no longer appears in Import panel > Devices


I wanted to scan some papers today, but my printer (EPSON XP-225) is no longer displayed in the Devices list (Import panel).

I’ve used it a few days ago and since then I didn’t update my Mac nor DEVONthink.

Tried restarting the app, but that didn’t helped.

The printer is connected on wifi and I tried printing (from DEVONthink) and it’s working great.

Any idea why I cannot see it in the import panel ? I need that because that’s my primary usage of DEVONthink :frowning:

PS : I have the Pro version

Thanks in advance

I really can’t help with how to get your computer to recognise the scanner … there are a myriad of things that could be interfering …

Meantime, get on with the important stuff of scanning your documents and instruct the scanner to put the files in a local folder on the computer, e.g. “Desktop”. Then simply drag and drop them into DEVONthink.

1 Like
  • Does it appear in Apple’s Image Capture application?
  • If not, have you rebooted the machine?
1 Like

Excellent. It wasn’t showing in Image Capture neither.

Rebooted the machine, and now it appears in both Image Capture & DEVONthink :smiley:

Thank you @BLUEFROG

My pleasure :slight_smile:

Before I forget, thank you for your suggestion :slight_smile:

I was going to suggest rebooting everything but you said you “restarted”. I missed “the app” and my brain said “the Mac”. Sorry.

Rebooting computers and peripherals usually fixes a lot of things.

We suggest rebooting Macs and iOS devices once a week or bi-weekly, just to be kind to them.
Some people even power off their Macs at night.

1 Like