Screen shot command opens up Devonthink

Hi there,

I have been using Devonthink for many years now and have not had problems until today.

The problem is when I press the screenshot commands it’s opening up Devonthink as a keyboard hotkey automatically (command + shift 3). Really annoying as I need to do screenshots for a project to show my client.

I checked already:

Preference-Keyboard - no accidently set hotkeys. I even restore default and still the same

I haven’t installed anything by myself these 2 days. However there was a small update from Apple which they installed automatically.

I restarted and the screenshot worked fine until 30 minutes later…

Anyone have any clue?


Did you try to remap the screenshot shortcut to a different key? You can do that in the system preferences / keyboard section. I use an f key for screenshot commands, it is really fast. After the last Leopard update, I had to re-remap my keyboard shortcuts for some reason.

Sounds like the Shift-Command-3 screen capture shortcut might be mapped to one of the Services > DEVONthink Pro menu commands.

Hi Scott. I don’t think so. If so, that should likely be visible by inspection of the DT Pro submenus under Services. But more importantly, those DT Pro Services are not functional unless an appropriate selection has been made.

One of the other possibilities I thought about was that a script to launch DT Pro might have been created, appropriately named so that keyboard shortcut would invoke it. Or a launch utility was installed and configured to launch DT Pro with that shortcut.

But in a message to Support, kidclam noted that the keyboard shortcut would work properly to take screenshots for a few minutes, but then start launching DT Pro. In other words, flaky behavior. It’s not consistent. It couldn’t have been initiated by DT Pro.

I did come up with a workaround. :slight_smile:

Make the screen that’s to be captured in a screenshot frontmost. Now launch Preview. In Preview, choose File > Grab and select the desired screenshot action. That will produce a TIFF image.

Personally, I use a screenshot utility that lets me control the size and/or quality of the captured image, and copy the resulting screenshot into the clipboard so that I can paste it into a Mail message or rich text document. I can include 5 or 6 images captured that way in a Mail message, but use less bandwidth than a single image captured using Apple’s screen capture keyboard shortcut.

kidclam hadn’t mentioned checking there, which is why I mentioned it. However, it does seem unlikely because:

… and that it was working before mysteriously stopping without any apparent system/configuration changes.

I installed the Pixelbreaker’s PolarClock Sscreensaver…maybe that is making funny errors… since the reason the screenshot doesn’t work after awhile is probably when I walk away from my computer…and coming back the screensaver is activated…

Seems there are no problems so far… the guys at DEVON tech should download it and try it out.