Security Issue with Reminders Script

I tried the DT3 script to add an item to Apple Reminders

I get this error:

I believe my Security settings should permit this. What else am I missing?

Interestingly this is on macOS 10.14.6.

My other Mac is running macOS 10.14. There the script DOES work. The security config there is a bit different however:

whereas on 10.14.6 (where the script does not work) there is no option to add Devonthink to Reminders:

Was an item selected? I just ran it here on 10.14.6 and it wors as expected.

Yes, an item was selected.

In fact just before and after the Reminders item failed, I was able to use the OmniFocus script to add the same item to OmniFocus.

  • Does it persist after you quit and relaunch DEVONthink?
  • Does it persist after a machine reboot?
    • If so, does it occur on another macOS user account?

Yes, it persists after relaunching DevonThink

Yes, it persists after a machine reboot.

I set up a brand new Guest user account. Same problem there.

Unzip this file and double-click it to open it in Script Editor.
Select View > Show Log.
Select a file in DEVONthink then choose Script > Run in Script Editor.

Where is it failing? (19.6 KB)

Your test script worked fine as described above

However the original script installed in DT3 still does not work - it still gives the error

If I install your test script in the script folder I get no response at all if I try to run it from DT3

@BLUEFROG - Any further thoughts?

Hold the Option key and choose Help > Report bug to start a support ticket so I can look at the logs.

Done- thank you

Jumping on this thread. I’m running the latest version of 3.0 (release) and when I try and run the Reminders script I get the error message below.

I’ve tried quitting and restarting. I checked the permissions and they are all find under automation.

@BLUEFROG worked through this with me on a support ticket.

The issue is that DT3 needs to be on this Security menu:

The problem is that if you inadvertently answered “No” the first time it asked for permission, there is no realistic way to fix that short of re-installing the whole OS from scratch or some other similar major redeployment of the operating system.

I settled on a workaround whereby I call the script through a Keyboard Maestro macro. The script works fine if it is initially called external to DT3.

Hmmm I did figure out the work around by manually running the script. I’m stunned that it would take a OS reinstall to resolve this issue. It’s a permissions issue and that should be something can be corrected.

Perhaps when I upgrade MacOS to the next version it’ll fix the issue.

1 Like

It’s a permissions issue and that should be something can be corrected.

It’s not merely “a permissions issue”. It’s deeper than that and Apple has not made any convenient or user-friendly way to change your decision on some of the Security preferences.


any news on this issue? I get the same error when I am trying to use the script. Would be nice if this gets solved soon.

Upgrading to Catalina did not resolve it

For now the only workaround short of an erase and fresh install of your OS appears to be executing the script from external to DT3, such as a Keyboard Maestro macro.

This is not a DEVONtech issue. It’s a combination of a User denying a request from an application and Apple not providing a way to undo that choice. Even worse, the Terminal commands that can be tried also don’t work to reverse this choice.

Thanks for the Informations. I already tried to undo this with the Terminal but it doesn‘t work. Hopefully there will be a fix from Apple or maybe another way from DT without using Keyboard Mastro or any other external App.

Is there a way to notify Apple of this issue?

I am positive Apple is aware of the issue. It’s not specific to us. It’s a general operating system flaw.
PS: Notifying Apple is no guarantee of anything.