Send Results via Email with Gmail SMTP-Server


I’m trying to set up my gmail account as SMTP-Server to send results after the search is done.

So far I did not manage that, I’m using in the prefs. the correct user name and passwort,, port: 587, and SSL activated.

But there is no mail in my inbox (different email then gmail account) or in the send items of the gmail account.

Any hint for me?



I don’t use gmail, for my own reasons. But when running scheduled searches I use my Mail address and that always works. To paraphrase a 1990s saw, “You’ve got Mail.”

Try port 465 with SSL.

same issue for me, is there a way to check a log file to see if there is an error with the SMTP configuration?


I have found the log file… it says that the message has no sender, why? I have filled all the SMTP preferences in DEVONagent, should I enter this somewhere else or is it a bug?

2017-02-09 14:31:14.903 DEVONagent[8354] Couldn't send mail to 'EMAIL REMOVED BY MYSELF':
Error Domain=MailDeliveryErrorDomain Code=11 "This message has no sender" UserInfo=0x618000e77b40 {NSLocalizedDescription=This message has no sender}

Does your Contacts card include an email address?

It’s not working with Port 465 SSL either.

Could we, please, keep this topic alive and try to get it working. It’s such an essential feature.


Has anyone figured out the trick to make DEVONagent send search-set results by email via Gmail? Like the folks preceding me in this aged post, I, too, am not able to send DEVONagent emails via Gmail to myself.


The easiest workaround might be to send them via Apple Mail (if that’s the email client you’re using).

Note of you use Apple Mail and have multiple accounts, the currently selected account will be the one the email is sent from. For example, if you have the Inbox of account 2 selected, the email will be sent from that account.