"Server Busy" while attempting to sync

I am having difficulty connecting and syncing multiple Mac platforms in DTPO due to the persistent message “Server Busy” while trying to connect via Bonjour. My apologies in advance if the resolution is already posted; however I have not been able to find anything recent (i.e., applicable to DTPO v2.9.2). Thank you in advance for any assistance you can provide, even if it is the blindingly obvious that I SHOULD have seen before posting. :smiley:

Have you restarted DEVONthink or DEVONthink To Go 2?
Do you have both ends of a Bonjour Sync set up? You shouldn’t, if you do. If you are not hosting a database on the mobile device, there is no reason to turn Bonjour On. (And obviously, if you are going to host one, then it shuld be On).

Jim: Thank you for the prompt Saturday reply. I restarted DTPO on both machines (MacBook Pro and Mac Mini) and turned off Incoming Connections on the Mini (making the laptop the “server”/host). Seems to be working properly now. Operator error on my part, evidently. Cheers, from Virginia, and many thanks.

I have the same problem since the sync was rewritten. Before my sync went perfectly well - I keep the data on my iMac, and sync it with Macbook, iPad and iPhone. Now even though I restarted both my iPhone and the iMac several times, sometimes the sync server is busy sometimes not, but even then it stops syncing. It is now totally unreliable for me.

I tried to restart all my devices, I even switched all when I was trying to sync one. I managed to start the sync on my iPhone but after the full night of syncing the phone became unresponsive and taps will take ages to get me wherever I want to go. I also tried to use DTP on my iPad but it is also unresponsive and crashes after I tap on anything. So, sync is currently totally useless.

How large is your database (see number of items/words in File > Database Properties)?

It is 22 Gb which I understand is big, but before the new sync I had no problem whatsoever after the initial sync.

And how many items/words does your database contain (see File > Database Properties again? Thanks!

It is 33 Gb… So yes, it is a huge database. I will delete On the Go, and sync the main database with gradually adding the files.

On the other hand, as I said everything went well with the previous sync so maybe the new sync needs some improvements.

The size does not really matter (as long as there’s enough disk space on the device), only the number of items & number of words are important.

To emphasize Christian’s point: when we talk about database size, the most important information is provided in Database Properties, and consists of two items: the number of documents, and the total number of words in the database. The file size of the database isn’t as important except (obviously) in terms of storage space required and (in the case of Sync) the data transfer time required).

For example, my main research database holds about 30 thousand documents and 40 million total words with a file size of about 5 GB. As most of my documents are plain or rich text, which require less storage space than it they were WebArchive or PDF captures of full Web pages, my database would probably exceed 60 GB file size had I done full page WebArchie or PDF captures. As I capture only the text and graphics that are the main information elements desired from a page, my captures are often from a tenth to a thousandth of the file size of a full page capture. Not only do I save storage space, but have more efficient searches and See Also results because irrelevant text is excluded.

According to the Database Properties, the size of the database is 17.5 Gb, 60,000 web pages, 98,000 total items, 998,000 unique words and 218,000,000 total words

Now I describe what has happened yesterday evening and today:

  1. I deleted GTG2 from my iPad.
  2. I restarted both my iPad and my iMac.
  3. I synced the iPad with iTunes.
  4. I downloaded DTG2 to my iPad.
  5. I restored my premium purchase
  6. I checked that Incoming connections is not enabled
  7. I added the direct location of my iMac from the list
  8. I saved it with the On demand download on instead of always
  9. I saved the Location
  10. I paired the iPad with my iMac.
  11. I tapped on my location and enabled my Global Inbox.
  12. All the metadata for my files in the Global Inbox was downloaded
  13. I tapped on “i” and changed On demand to Always
  14. I synced it and all the files (only 7) were downloaded.
  15. I went back to Edit locations, chose the local network and enabled my database which has more than 90,000 items
  16. The metadata of the 99,000 items started to download. After 30,000 items the sync slowed down
  17. The Activity window on DTPO correctly showed Syncronising items to mobile@ipad-local
  18. After around 77,000 items the sync stopped and the Server busy error message stopped the sync.
  19. I exited DTPO and restarted it.
  20. As my database was empty, I started again the sync where only the remaining 22,000 items started to sync.
  21. Item syncing finished quite soon, and then the tags of my database started to sync, with the ones starting with a Capital letter first.
  22. Downloading the files started immediately.
  23. As it was after midnight, unfortunately I have fallen asleep. When I woke up around 5-6 hours later, the system was not doing anything.
  24. When I tapped on the cloud icon on the main page the system synced the 300 items which DTPO downloaded during the night, and started to sync the Tags.
  25. The blue part of the grey line showing the progress of sync did not move for hours.

So sync does not work for me when I am using my database. The process is the same for my 2 iPhones also, so it is now 3 devices I am unable to use the sync.

The previous version worked perfectly well. I think it is a mistake that I cannot choose to sync incrementally.

Maybe we should move this to another topic. The solution for Server busy is what you described: restart DTPO and DTG2.

I have been getting the “server busy” much more frequently. I have a Mac, iPhone and iPad that sync with Bonjour. The error used to occur sporadically, but as I add more items to my databases it seems to be occurring regularly.

The only way around it is restarting DTTG, DTPO or both.

This has been resolved for me with the latest updates. Everything is running smoothly.