Service: Save to Sorter's Inbox

This service does not work.
OSX 10.10 DEVONthink Pro Office 2.8.1
System Message;
2014-10-20 12:45:24,732 Mail[3826]: Object <MailTableView: 0x7fbb56463c50> could not or did not write the selection to the pasteboard in preparation for a service request
2014-10-20 12:45:24,742 DEVONthink Sorter[510]: sURL = (null)

I have just tried the “Save to Sorter’s Inbox” service and it appears to be working here. Is there a particle application or content that it is not working with or is for all content?

I should have been more specific.
This is what I meant:
In Mail, select a mail, use contextual menu and select “Save to Sorter´s Inbox”.

I tried selecting text in the mail, and then using the contactual menu and that part works fine.

I really thought that my first approach should have worked too.

Have you tried selecting text in an email, then click-hold-drag the selection to Sorter and drop it into the Inbox (or some other destination)? Over here this works well and creates an RTF containing the rich text of the selection.

the Sorter is working fine, and that is the only method I´m using right now.

I do have a related question that you may be able to answer. Using drag & drop the following happens;

  1. If dropped in Sorter the “name” of the mail stays as is (in Mail)
  2. If dropped into DEVONthink Pro Office Global Inbox or other group the “name” gets an extension of “…eml”. This part I think is new (but it could be one of those “never noted things”.

Not sure about your exact circumstances, but email message files have an .eml extension and are stored that way internally in your database. Whether or not documents are displayed with an extension in your databases depends on this setting in DEVONthink > Preferences > Import

See Help for more details on that setting.

In Pref I have selected filename without extension.
This is not a big thing, I was merely curious as to why drag & drop directly to DEVONthink Pro Office resulted in the elm extension, when dragging to the Sorter provides none (more in agreement with my Pref selection).