Setting up new instance, lots of "File not yet available" pending files


I know this has come up a few times before, and I’m a bit stumped (also frustrated).

I’m migrating to a new Mac, and on the new Mac, for several of my databases, I end up with several dozen (out of several thousand) files that are “pending” on the new instance and show up as “item is pending.”

I’ve verified both old and new, and it doesn’t report issues. I’ve verified, checked file integrity, and rebuilt the database on the old Mac. I’ve cleaned the sync from the old instance and re-created it. Nothing I do changes it - I end up missing the same files on the new instance.

I’m syncing via a local WebDAV instance (Synology). I also tried syncing using Bonjour and had the same problem. In the past, when this happened, I duplicated the files in this funny state and then deleted the old one, and everything worked. This time, there are like 60 files, and I’d rather not go through that.

What gives? It seems like this bug has persisted for years—any help is much appreciated.

Follow-up: OK, I see what’s happening. I have a few files in the database elsewhere in the file system as if I indexed a few individual files. Is there a way to see which files in a database are not located in the database directory?

- Eric

I’m guessing the files you notice might be indexed (not imported) files? Assuming this is the case, do they actually exist in location that DEVONthink thinks they exist? Any clues in the log?

Yeah, that was it. I was able to create a Smart Group that showed indexed files, and then use the Move Into Database command. Problem solved! Thanks for the suggestion.

Have you read the Help and our most recent tutorial on indexing?

Not recently enough, and no - will have a look, thanks