Setting up workflow with DTPro, Bookends, & Scrivener

Thanks for the thought @BLUEFROG – but no, no VPN.

I should probably clarify my issue. I had the problem when adding a PDF on an iPad into Bookends for iOS – which of course requires the use of iCloud sync. The newly added PDF then did not show up on my Macs (I think perhaps the reference did). Things seemed to work when adding a PDF on Bookends for Mac – everything showed up correctly on iPad, at least the one time I tried it.

When I hit the issue on iPad, I did do some troubleshooting (disable/re-enable the sync; rebooted things) but couldn’t get it to work. As I have never used iCloud sync for any other kinds of file sync (I don’t trust the reliability of Apple cloud anything for anything important), but have used Dropbox for years without ever having a file not sync, I decided I was going to give up on Bookends for iOS, and just use Bookends for Mac with PDFs in Dropbox and indexed in DT3, and thus also showing up in DTTG.

I can think of a few loci for the issue I encountered: (1) how Bookends works with iCloud sync (2) how Bookends for iOS works with iCloud sync (3) iCloud sync itself (4) something on my end. So I suppose the issue is not necessarily iCloud sync itself. But given that things have just worked with Dropbox for over ten years, I was not willing to spend any further time on troubleshooting.

Hope that made sense.

This is happening to me as well. Same set up.

I did an experiment to try to identify the problem. I added a record with an attachment to Bookends. I then checked on all three computers to ensure that the new attachment was showing exactly the same in each computer’s iCloud directory—which they were. I then opened DEVONthink in my base computer, and it showed the new file in the Bookends indexed directory. So far, so good. However, when I went to my second computer, it synced with the Dropbox store, and then showed the file twice, with both files having different timestamps for Added (with the timestamp being the moment I opened DEVONthink). I then went to the third computer, and the file was now in triplicate, with its timestamp for Added also the time when DEVONthink was opened. I have attached a screenshot that shows the triple listing of the same file. I hope this helps to isolate the issue.

No VPNs are being used.

Are you using Dropbox’s Smart Sync feature to keep the file online until you download it on demand?


But the Apps directory in Dropbox, which I believe is where the DEVONthink store is, is not listed as one of those on-demand.

Ahh… your Bookends attachments are in iCloud but you’re syncing to Dropbox.

Are the files in iCloud being stored locally or being downloaded on demand?

When one activates iCloud Drive, a directory with that name appears in the Finder that shows the contents of iCloud Drive. I did not know that one could choose not to have the files in iCloud Drive downloaded.

That is why I use Paperpile. PDFs are maintained in Google Drive. I índex them in DT3 and have the best of two worlds. An excellent reference manager and a wonderful document manager.

@BLUEFROG : I think I have some relevant new information. The Bookends attachments folder is the only folder I am indexing in DT, as opposed to all the other folders, which I imported into DEVONthink. I have never had this problem with duplicates with any other folder in DT, so I decided to index another folder from my hard drive that wasn’t already in DT as a test. Sure enough, after indexing the folder, once I added a pair of files to that directory in my computer, the duplication started in the other computers once I opened DT in them. So the issue is linked to the folder being indexed —as opposed to residing in the DT database— and it does not seem to be related to its residing in iCloud. Is this helpful in determining what may be causing this behavior?

Is the second folder you indexed also in iCloud?

No; it’s just in my computer’s hard drive.

  • In your Documents or on your Desktop?
    • If so, do you have System Preferences > Apple ID > iCloud Drive: Options > Desktop & Documents Folders enabled?

Not in either of those folders. The folder I indexed is on its own in the root directory. I do not have Documents or Desktop enabled in iCloud Drive.

So this is just a random folder in the root of your home directory that is only on this machine?

The same folder exists in the other machines.

Okay. And it’s synced only via DEVONthink to the other machines or via another process as well?

It is synced via Resilio Sync as well. I can always turn that off, but this does not address the main issue of duplicates when indexing the Bookends iCloud attachment folders.

You have so far identified two other syncing processes: iCloud and Resilio.
Yes, please disable to Resilio sync and see if the behavior persists.