Share PDF from DTTG not working?

Hi, I’ve been meaning to query this for a while but I have been assuming it’s a problem with me since no-one else has mentioned it! I’m on DTTG 3.7.2. And I’ve only tested this in iPadOS.

If I am in DTTG and I’ve downloaded a PDF (I download on demand), if I click on the iOS sharesheet button, it shows the usual options for where to share to. Let’s say I pick “Save to Files”. However, it doesn’t work. Its shares a text file, not the original PDF. The file is always the same: it just has the name of the PDF I’ve tried to share. Sharing the PDF to Readwise’s Reader doesn’t work either, though I’ve not been certain whether that was a DTTG issue since Reader is in beta and has only recently improved its PDF handling. However, GoodNotes doesn’t come up as a share option, which I think means the iPad isn’t recognising the file as a PDF for sharing, so the problem is occurring inside DTTG?

Anyway all this means that currently I can’t export PDFs on iPadOS and have to go back to my Mac to do it, which is not ideal. Has anyone else come across this issue?

I just tried it here and it worked as expected. I saw a crash (that I couldn’t reproduce) but the file was actually shared. Can you drag it from DEVONthink To Go to the Files app? That’s a different mechanism. And restarting the device might also help.

Ahh I did wonder if it was an issue with my device since no one else had mentioned it!

Do I do that by opening in Split View and dragging the file from the DTTG window to the Files window? If so, no that doesn’t work either. It does the little graphic that shows you’ve picked up a file, but it doesn’t add anything to Files when I release it.

Ignore my previous answer. Foolishly forgot to test it with a downloaded file :roll_eyes:

Yes, this works if I download the file.

Restarting the iPad hasn’t fixed the sharesheet issue (I didn’t expect it to really as this has been going on for weeks and I’ve probably done a restart or OS update in that time).

Drag and Drop is a fine workaround, and I’ve been living with this issue for a while anyway, but it would be good to figure out what the issue might be. Here is my sharesheet menu, I think the sharesheet is saying this is a text file straight away, is that what the file icon means? So iPad doesn’t recognise it as a PDF?

The file is a PDF, and in DTTG it is listed correctly as “PDF+Text”. I’ve tested a couple of PDFs from different sources (e.g. ones I created myself via ones downloaded from the web) and it’s not a source issue.

Yes, this icon means it’s been shared as text. What have you chosen in Settings > Share & Integration: Share? When you set it to Markdown, a Markdown-style item link is shared.

1 Like


The share setting was set to “link”. Changing it to file has fixed the problem.

I want to say that this is a complete mystery and I have no idea how this was changed. But in reality I have a terrible habit of going into menus and changing settings I don’t understand to see what happens, so it’s quite likely I did this myself months ago and then forgot about it.

Thanks so much for your quick troubleshooting!


My pleasure, @MsLogica