Show Only Documents not preserved between groups when using back and forward buttons in path bar

The setting “View > Show Only Documents”, which is supposed to be set per-database, loses its setting when you use the ‘back’ and ‘forward’ buttons (to the left of the path bar at top) to navigate between databases.

So, if you’re viewing a group in database A that has “Show Only Documents” ON, and you use a button to go back (or forward) to some other group in database B which has it OFF, and you then return via a button to the group in database A, that will have taken on database group B’s ‘OFF’ setting.

Navigating using the leftmost pane doesn’t result in this changing of the setting.

Not sure if it’s a bug but it’s confirmed. @cgrunenberg would have to assess that.

  1. Set a database to View > Show only documents.
  2. Choose a second database without this option enabled.
  3. Press the back arrow in the Navigation bar. The first database ignores the option. Checking the View menu shows the option as disabled.
  4. Select the second database, then the first in the Navigate sidebar and the first again honors the setting.

The next release will fix this.