"Smart dashes" substitution doesn't stay checked

When you’re editing a note, right-clicking brings up a context menu with Substitutions as one of the options, and then Smart dashes (i.e., replacing – with —) as one of the options under Substitutions. My problem is that no matter how many times I select Smart dashes to turn it on, as soon as I create a new RTF file/note, it’ll be turned off (unchecked) again.

I don’t see anywhere in the DTP prefs to set this permanently (the two options that are permanently turned on for me (Smart copy/paste, Smart quotes) are in the DTP prefs under Editing)…is there anything I can do to turn on Smart dashes permanently?

I’m running OS X 10.7.4 and DEVONthink Pro 2.3.5 (beta version for syncing).

Thanks for the suggestion, this is not yet possible but we might add a new preference to upcoming releases.