Smart Rule Name does not begin with issue

Trying to narrow down a smart group to NOT include certain records, but can’t get it to work like I expect. Here is a screen shot of the rule and the record that I think should NOT be showing up.

If I change the “Name does not begin with” criteria to specifically be "6) " then the record does not get included in the selection. But leaving it as "[0-9]) " does include it… what am I getting wrong?


I tried that sometime ago:

You’re not doing something wrong as …

… so you need to check for each digit independently.

Press the option key to create nested conditions:


Thank you! I did not find that thread in my search. Your help is much appreciated.


1 Like

Exact string comparisons like is/contains/begins/ends (not) don’t support wildcards. NOTE: If operators and/or wildcards are supported by a field, then the placeholder of the empty field explicitly mentions this.

1 Like