Smart Rule trigger on scan

I have two related questions about Smart Rules.

  1. Can you confirm that the intended functionality of Smart Rules is match criteria -> match triggering event > execute actions without manual intervention? I’ve read the documentation from the Help.
  2. Can you look at the attached Smart Rule and discern why it is not executed automatically? The intended workflow is Scan (iX1500) -> after OCR look for certain content -> apply tags, rename, move.

Currently, if I scan a document that matches the criteria. I see a document count on the relevant Smart Rule line; but it is only executed if I select “Apply rule”. Is this the intended functionality or am I missing something?

just an idea - I wonder whether [Perform the following actions:] “on import” works; have you got DT set up to enter metadata after scanning? I’m just guessing that in the context of smart rules DT either doesn’t treat OCR which is automatically triggered by the settings in the same way as OCR manually triggered, or entering metadata means that OCR wasn’t that last thing performed and the smart rule isn’t triggered for that reason. As I said, just guessing. Perhaps give it a try and post the result :slight_smile:

(sorry, I’m tired: my unstructured response is in regard to your question 2; I think the answer to 1 is “yes”)

Thank you. Attempted the two solutions.

  1. “On import…” - no change; the matching documents are “accumulated” in the Smart Rule document count, but nothing is triggered (as before)
  2. Disabled metadata entry on scan - no change. Same as above.

Ar. I have rules that are functionally identical to yours (although I use “on import”), and they work. Presumably you are scanning to inbox (using the settings below; not saving to inbox directly)? And, because I can’t think of anything else (@BLUEFROG Jim, help me out here :roll_eyes:) have you restarted DT/the Mac since setting up the smart rules?

How have you set up your scanner? Again, just wondering whether your scans are arriving in DT differently that mine are. My scan profile is as so (the important bit must be the managing options and the application, at the bottom).

Thank you for pursuing this so diligently. The scan profile looks exactly the same except for a different in file name format. So strange.

1 Like

I’m out of ideas though, I’m sorry :neutral_face: hang on in there and one of the DT folk will respond with a simple solution (I hate it when they do that :crazy_face:)

Actually, one last thought - where is your smart rule? Mine are listed in the side bar at the very bottom, ie are not in any database, but are instead global. And I’m using DT 3.0.4. Presumably also the database you are trying to send to is available (I think I understood you to say the rule worked if triggered manually, which would exclude that problem)

This is correct.

A screenshot of Preferences > OCR might be useful too. In addition, which version do you use?

But actually it’s an import event in this case (performing OCR or not depending on the preferences), therefore the triggers on scan or on import should work.

Version 3.0.4

This looks fine. Did you notice my second reply?


The On OCR trigger is only initiated when using Tools > OCR, not when scanning inside DEVONthink with OCR enabled. Is that correct and intended?

If the actions ran synchronously, i.e., top down, it would be possible to use an On Scan trigger and an OCR > Apply action at the top with the subsequent actions waiting for the OCR to be done before running.

We already tried that :wink:

Technically, if you used the OCR in ScanSnap Home, it would process outside DEVONthink, then send the resulting file to DEVONthink. An On Import trigger should work in that case.

Since there are a couple sub-threads going here, I’ll just summarize:

  1. By combination of: disabling metadata on OCR preference, changing the rule trigger to “On Import”, adding “Cancel” as final rule action, and restarting DT, the majority of rules new fire automatically.
  2. A single rule, structured in every relevant way similar the other functional Smart Rules, does not fire automatically. I duplicated it, deleted the original, restarted DT. No joy.


Is this still the one shown on the screenshot? A screenshot of the similar rules might be useful.

Move the billing coordinator one above the LHSC one. Does it still not work?

Sadly, no; the order makes no difference.

Are you saying it doesn’t work on import or even when applying the rule?

It doesn’t work on import. Manual application of the rule works.