Snippets don't paste in Catalina?

Just upgraded to Catalina and now when I select a Snippet, it copies but doesn’t paste automatically. In Mojave, it would copy to the clipboard and paste into wherever my cursor is. Looked in the settings and didn’t see anything. Did I miss something or did this functionality change recently?

Welcome @nebula42

This is a sporadic issue with XMenu we can’t reproduce at will in Development. It is still under investigation.

Is this a new machine or a fresh install of Catalina, i.e., not upgraded from Mojvae?

Thanks for your patience and understanding.

This machine was running High Sierra but recently upgraded to Catalina (skipped Mojave on this machine because it wasn’t in use for a year or so). XMenu was already installed and appears to be up-to-date.

Everything works fine on my laptop, which is running Mojave right now.

Did some digging in the system preferences and noticed that XMenu is listed under Automation in the Privacy settings on the Mojave machine but not on the Catalina machine. Tried to see if there was a way to add it but it looks like maybe the old app must have asked for permission because from what I have gathered that is the only way to get it listed on there. Not sure if that is related at all but know that setting controls some interactions with other apps at least.

Thanks for the quick response and glad to know you are looking into it.

You’re welcome. :slight_smile:

I have the same issue on my new 16" MBP with Catalina pre-installed so at least I can confirm your findings.
And unfortunately, Apple hasn’t made the mechanism very easily adjustable and it’s inconsistent in any resets I’ve tried.