[SOLVED] Mounting an encrypted database does not work anymore

I was short of getting into panic, as one of my encrypted databases simply could not be opened anymore …

“Recent databases” and then “Open database” just did nothing at all.
The others asked for their password.

I then had a look at the files:

Screenshot 2021-09-02 at 22.50.44

So, this one database has an file ending of “.dtSparse”, while the other encrypted databases have “.sparseimage” …

Should I try to rename the ending?

I SURE did not rename that before … how can that happen?
Is this the reason for the problem even?

Now, that did not help at all.

I copied the file and changed the ending to “.sparseimage” but it cannot even be opened with DT - it is greyed out.

Slowly, the panic is coming back …
That’s my main database, as the name suggests

EDIT:

Ah, I understand.

The images are named *.sparseimage after opening with DT.
Before, they are all named *.dtSparse

Correct; see here for more info on that.

Have you tried rebooting?

Helo Blanc,
no, but I will try a reboot!

Before doing that, I noticed this:

ini:Databases tja$ df -k | grep -E ‘(MAIN|RPG|XXX)’ | sed ‘s/ */ /g’
/dev/disk4s2 8052696 3113240 4939456 39% 1081 4294966198 0% /Volumes/MAIN
/dev/disk5s2 3858392 2590136 1268256 68% 382 4294966897 0% /Volumes/RPG_TJA
/dev/disk8s2 8052696 1816632 6236064 23% 875 4294966404 0% /Volumes/XXX_NEW

So, the volume got opened …
But it is not visible in DT or in Finder.

So, I umounted manually with “umount” and tried again with DT:

The database opened and was visible in DT!
BUT, it did not ask for a password at all.

Maybe somehow, the password got saved in the keychain (which I sure don’t want)?
That would have been by accident only.

Also, then it should have been added to DT in the first place, which was not the case.

Very strange.
Going to check the keychain, delete the password and try again.

Sorry for all that noise :slight_smile:

AND, the database shows a little symbol:

Screenshot 2021-09-02 at 23.34.15

Read-Only?!?

Whatever the reason was, after the reboot, I could open the database again!

Sorry for the noise :slight_smile: