Sorter problems using anything but mac mail


I don’t use mac mail, but mailmate. Is there a reason why I can drag emails directly into a database group from mailmate, but dragging them to the sorter does not work?

When I drag the emails to the sorter the activity indicator tells me something is happening, but nothing ever does. I can come back an hour later and still nothing has been imported and the activity indicator is still spinning round. I’m only talking of ten emails without attachements. Same problem using Postbox. The sorter only seems to accept emails draged on from apple mail, which is pretty pointless as this has intergrated import support.

Is there a solution to this

Mailmate is an IMAP email client, which means that your messages are actually on a remote server, and are being displayed (but not stored) locally. I’m not familiar with Mailmate, but some IMAP apps let you actually download copies of the message files to your computer as an option.

The Sorter handles capture of files that are on your computer. In the case of Mail, copies of the messages are files on your computer, and can be captured by the Sorter. My guess is that dragging the displayed message from Mailmate doesn’t work, because there’s no file to capture.

So how is it that I can drag the emails directly into a DT group and it works, but not onto the sorter? Does the sorter have inferior capabilities?

This has to be a bug.

I just tested it with one email and it works, but it doesn’t work with multiple selections. I’ve also checked and Mailmate does store local copies of emails on the harddisk in .eml format.

Until DT can fix this I will quit the sorter as it has no value for me.

I would appreciate some feedback that this should work. If it works with one it should work with more than one?

As there seems to be no support I have removed the sorter feature. The sorter is one problematic piece of rubbish. Dragging items in directly works far better and isn’t riddled with problems.

So far: The sorter does not import more than one email at a time from anything but mac mail. If it does import the one email it gives it a number and not the subject of the email. If you attempt to import more than one email the activity icon keeps going round and round until you exit the sorter.

Devonthink, please get this sorted. :frowning:

Just a sample of one over here, but I can successfully drag any number of messages from Apple Mail into Sorter – DEVONthink Pro Office 2.4.2 on OS X 10.8.2. I don’t have Mailmate; so can’t test it; but if Mailmate stores RFC-compliant IMAP records locally in your configuration, then the result should be the same. Just my opinion, but I don’t think Sorter is broken.

As stated in the previous emails, it works with apple mail, but not with anything else. I’ve tried Mailmate and Postbox. Both Mailmate and Postbox store local copies of emails. If I drag the emails directly into a DT database it also works, which leads me to believe that the sorter is broken.

OK. Curious and having time, I downloaded Mailmate and tried dragging from there to Sorter. There are problems, similar to what the OP reported, but I’m not sure it’s a DEVONthink issue. FWIW, I opened a ticket with DEVONtech Support and submitted the console errors that Sorter was tossing off when I dragged messages from Mailmail to Sorter. The OP could file a report, too, if desired.

OTOH, Mailmate is an unsigned app, seems to toss off sandboxing errors, and doesn’t download standard mail files.

I have now filed a bug report. Thought I’d try the forum first.

If this is not a DT issue I would be interested to know what would cause other email clients apart from apple mail to not work. It could be to do with apple attempting to close their eco system by excluding any apps not from the app store or part of the developer programme. However, I have disabled this function to allow all apps.

The data is being transferred into an NSPasteboard in some fashion. Dragging files for some nerdy reading. Even at a casual glance you’ll see it’s not so obvious a problem.

Sorter still not sorted

I’ve recently upgraded to 2.4.3 and can confirm that the sorter does now allow more than one email from email clients other than mac mail. However, this is only half the problem.

If I drag emails into DTP they appear with the subject as the document name. This is good. If I drag the same emails into the sorter I get "48761.eml, 48762.eml, etc… This is not good.

So once again the sorter gets uninstalled as a waste of space.