.sparseimage Backup not working

Hi, I am trying to access a .sparseimage Backup of a database I have in DEVONthink, but I can’t open it.

The backup was done with Time Machine.
I need to access a backup version of a Rich Text Doc, as I copied some text, forgot to paste it right away, so I lost that big chunk of code.

When I try to open the .sparseimage file (Organization.sparseimage) with the Finder, I get a message telling me that “The vault file is not writable. You don’t have a permission to write to the vault “1-Organisation”. Please repair the permissions and try again.”

Any tips on how I can get access to it, or any other ways to access documents in DEVONthink encrypted databases when they are backed up as a Time Machine Backup?

Thanks a lot.

How did you try to open the file with Finder?

What I would do would be to:

  • close all databases in DT
  • rename the restored database “Organization_Restore.dtSparse”
  • open the restored database with DT
  • restore the individual file by copying it from DT to desktop
  • close the restored database in DT
  • open the current version of the database in DT
  • copy the file from desktop to DT

Take a moment to read this post.

If the problem you are reporting is a real permissions issue, then please post here the the information provided at the bottom of the info window in Finder (select Get Info from the context menu of the sparseimage file in Finder).

Hi, Blanc. Thanks a lot for your reply, I appreciate your help, and sorry for the delay for my own reply to this.

Apparently I could’t rename rename the file with Forklift (my alternative Finder app).
“The item “Organization_Restore.dtSparse” can’t be renamed”
“The operation couldn’t be completed. Permission denied”

But was able to rename it via the Finder itself.
But when I try to open it with DT, I insert the password and everything seems to work, but the Database is just not loaded. So in DT I can’t see the Database at all.

I am reading the page behind the link you’ve sent me, to try to figure out all this stuff.

Any additional help would be appreciated.

Thanks, G.

That sounds as if it may really be a permissions issue; select “Get Info” from the context menu of the database in Finder - check the permissions listed at the bottom of the info window.

I got “Read & Write” for my account (me).
Then “Read Only” for: Staff, Everyone

Changed it “Read & Write” to all three, just to see.
Same thing. Database asks for password, then it just doesn’t appear in DT.

Please reset the warnings in Preferences > General and try to open the database again. Does DEVONthink show an alert?

No, it doesn’t show alerts, actually.

Does rebooting the computer make a difference?

And just to be sure: did you close all other databases before attempting to open the restored database?

Yes, I did that. And even re-launched DT.

I think I rebooted yesterday and then tried today. But I’m not sure if I did before trying to open the restored database. I’ll try that again, so that I know.

So in DT I can’t see the Database at all.

A screen capture of what you’re looking at may be helpful.

Hi Bluefrog,

The only screenshot that would make sense to show would be the info windows.

  1. Left = Working Database (with the file in which I deleted some text that I need to copy from the backup)
  2. Right = the backup version (from Time Machine) of that database, renamed as Blanc suggested.

When I try to open it with DT, I get the pop-up for the password. When insert it, the pop-up disappears, as if everything it’s ok. But in DT the database is just not visible. I can also try to open it again, and same pop-up for password appears.

I do have a Backup from Time Machine on an external disk, if there is something I can do from there.

Thanks for the help, by the way.

I did try to check all the Write permissions for the file, and still didn’t work.
In the screenshot you don’t see that because I put it back to the original/default way.

I did restart the computer, closed all databases in DT and tried. No difference.

Please change the extension from .dtSparse to .sparseimage and then try to mount this disk image in the Finder. Does this work? What does the mounted volume contain?

Criss, the file was originally a sparseimage file; it had been backed up that way (i.e. as an open database); it was renamed at my suggestion to see whether DT could open it. In their first post, the OP said (referring to the backup, which was only later renamed to “Organization_Restore.dtSparse”:

So presumably - as it won’t open with DT either - there actually is something wrong with the backup (was it never a working backup because the database was open at the time it was backed up…?). @gian can you restore a slightly older version of the database (i.e. by going back another day in TimeMachine)? Perhaps that might work (assuming your content was old enough to be included in that older backup).

Hi guys! Again, thanks a lot for your interest in this, I appreciate it.

Blanc, there is, in fact, a big chance that I backed up with Time Machine while the DT databases were opened, as I always keep them open while working.

It is kind of new knowledge to me that backing up while the databases are opened, would result in not being able to access the files in the backup.
If that is the case, then I don’t think I can recover it and if anything, I will have learned a big lesson here, for the future. So, while backing up with Time Machine, I should keep the databases closed, right?

The databases were certainly open when they were backed up, as indicated by the file ending. In theory a snapshot is produced before the backup is copied to Time Machine and as a general rule I would expect a backup of an open database to work. My experience with databases prior to DEVONthink does however suggest that things can go wrong. Criss or Jim may be able to say more about any risk involved. Like you, I back up open databases but I do regularly close them to ensure that I also have a back up of closed databases. I still think it would be worth trying a database copy which was backed up slightly earlier, Even though that will have been an open backup too.

Ok, I see. So, the “backup while database is open” is not something not to do because it’s supposed to work only when databases are closed. It’s a little bit a random problem.

I will have a look and see if older backups would work. But as I said, until now I always backed up with DT databases opened.

I did a Backup with Time Machine, closing all the Databases.

I can open the backup version with DT (closed all databases), but apparently, I can only read the files, not write them.

Is this a normal behaviour of the backup version?