Spotlight in Scrivener files

Just transferred everything to a new MacBook Pro 15", and in the spirit of consolidation dumped a few dozen Scrivener files into Devonthink. Spotlight works on *.scriv files in the OS directory, so it should work in Devonthink, shouldn’t it?

It doesn’t.

If I drag a .scriv file out of DT, Spotlight operates on it. Inside Devonthink, the file is invisible. Is something to do with .scriv files being a package?


What does that mean?

Did you enable Spotlight indexing, see File > Database Properties?

Korm - I mean that Spolight finds content in .scriv files when they aren’t in DTPO.

Christian - this is my main working database. Spotlight is integral to how I use it, so yes, it’s turned on. It finds content in Mellel files that were dumped into DTPO at the same time, but not Scrivener files.

Just tested this. It works over here. Imported a .scriv to DTPO. Spotlight found the original and the imported copy in DTPO, based on a string in the file’s content. Try to “rebuild” the Spotlight index by chosing the button in the database properties.

Done that, same result. But then I used the Search window to find all my 109 .scriv files (2 seconds), highlighted them and exported them all to a folder on the desktop (60 seconds), trashed the highlighted files (1 sec), and reimported the .scriv files from the desktop (60 seconds). Problem solved. I’ll leave the problem of “why” to the DevonTech people.

Thanks for trying to puzzle it through with me.