Strange DropBox Sync issue

Notice this afternoon that my iMac and MacBook Pro (DT Pro 3.0.4) were out of sync. Looking at my iPad and iPhone DTTG, sure enough, all 4 had different global inbox contents.

Using Bonjour, got my MacBook and iMac in Sync. However, as soon as I remove this option, no Sync between computers.

Next, I remove DTTG on my iPad, reinstall (no database or document - fully empty!) and download the global inbox using DropBox. Surprise, the newest document was from end of November 2019 and it won’t Sync with the latest Database on my MacBook Pro (the master!).

Devon tells me that the location and database(s) are all OK and the no failure message in the Activity or Log or Download manager (under Window).

I am open to suggestions!

By the way, just notice a French spelling mistake in the Sync pref: Disponilbe -> Disponible. See the attach screen capture.

There may be a fairly rare and non-reproducible issue with Dropbox syncing - it seems most likely to be on Dropbox’s end. DT support tried at length to work through it with me - I had to give up and use CloudMe instead.

We are unable to reproduce any issue so far and we have also not changed any of the code regarding Dropbox sync in a long time.

Select the sync location in DEVONthink’s Preferences > Sync, control-click the problematic database in the Databases list, hold the Option key, then choose Verify Database Thoroughly.
What is reported in DEVONthink’s Window > Log?

If it verifies successfully… In DEVONthink’s Preferences > Sync, click the plus button under the Locations list and choose Add Dropbox Sync Store. Give it a new name and enter an optional encryption key, if desired. Choose the smallest database and sync to this new location.

Then add the location to DEVONthink To Go’s Settings > Sync: Edit Locations and/or the sync locations in DEVONthink on other Macs. Disable the old sync location but don’t delete it yet. Sync to the new location, then make some minor changes, like changing a label color on some files to see if it syncs correctly between the Mac and mobile.

In the end all the verification of location and databases were good (according to DTPO) and nothing in the log. So, I removed and clean the location of the DropSync on my iMac and MacBook Pro as well as removing the app on all iOS devices. Started a new DropSync on my main computer and Import on the other devices.

The Import on my iMac looks OK. However the iOS global inbox have 32 older files that are not there on my MacBook Pro or iMac.

Following this, I move one file from the master computer global inbox to another database. The file is not remove from the Global Inbox on the other computers/iOS but I can see it in the other database. Again no error or other messages in the log…I am concluding that the issue is the Global Inbox Sync since the other databases seems to sync properly.

I further confirm that if I move a file from the global inbox on either my iMac or iOS devices to another database, the file does not disappear from the global inboxes of the other devices but is Sync properly to that target database across all devices…

The next release will fix this.

1 Like

I clean again the location and resync. This time the global inbox worked on all devices. Still have no idea why it stop working in the first place …

I can easily reproduce at least some of the long-running sync bugs on my systems, and the sync bugs make DT3 extremely unsatisfying for me to use. Which is beyond frustrating because I love DT3 and it is part of my daily life both at work and at home. I depend on it, and the fact that sync is not reliable causes quite a bit of stress.

I happily volunteer to run an instrumented build so you folks can diagnose and fix these problems.

  • Eric

It would be interesting if you would run a parallel sync for a short time on CloudMe and test (1) Do. the Dropbox issues recur; and (2) If/When the Dropbox issues do recur, does CloudMe Work?

I’ve never used CloudMe, but I’m happy to give it a shot and report back.

As soon as they restore the ability to create new accounts on their website :frowning:

If you go here and choose consumer pricing and set up a new account, what happens?

When I click on “Continue to PayPal” after entering a usename, password, and a few details, I get an error message, “Purchase failed, please try again later.” Both Safari and Chrome. I also downloaded the client and tried from there, but I get the error, “Failed, please try again…”. Seems like their backend is having problems, I’ll keep trying until it works.

You can sign up for a free account just to test it. They give you 3GB of storage.

That doesn’t work either. Their backend is hosed. I’ll keep trying.

(Not exactly giving me confidence this is a service I would want to entrust my data to…)

Yes, try again later. I just connected to my (free) CloudMe account (first time on this machine) and imported a database I had synced maybe two years ago.

It must be some sort of regional issue.

Syncing data is mission-critical for my small business. A number of months ago Dropbox stopped working for me but Devonthink support could not duplicate the issue. CloudMe has been rock solid for me since then.

Hard to explain either issue unless/until we can predictable reproduce the issue(s).

The issue back again.While DTPO tells me that Sync is ok the content of the two are clearly out of sync…as far as I can tell since March 9th…This is really a major inconvenience as I now have to manually go aver all the Groups and manually find which file is missing on which of my main two working platforms.

DTPO? Are you running DEVONthink 2.x still?

And as noted, this is not an error we can reproduce at will and we have no other recourse at this time other than the instructions I noted above.