Strange issue with stubborn 'always open' group

I have one group that is always open when I select a specific database. It is the top group.

In other words, when I open a typical DB, groups are all closed. When I open this DB, the top group is always open and its contained group is also open. So the top group is fully expanded.

I have tried closing and reopening the DB. I have tried closing all groups, then closing and re-opening. I tried rebuilding the DB. No luck.

There are a lot of contents in this group, so I always have to scroll down a good distance. Quite inconvenient.

Is there a keyboard shortcut I am missing?

Is there something else I can check?

1 Like

I get this a lot too. Not even the top group always. Nothing I tried worked. I found it happens a lot with workspaces which I use extensively and ‘updating’ them with the groups closed doesn’t change the behavior as I would have thought it would.

There used to be a short cut that opened every group and one that closed every group. I forget what it was and can’t find it again. I would love to know if it is still doable as it was very useful. Apart from dealing with this weird glitch.

Expanding or closing a group while pressing the option modifier key expands or closes all child groups.

1 Like

Thank you. Unfortunately, it doesn’t ‘stick’ and next time you select the database, its back to the same issue.

From what I’ve seen in internal Vera’s, this should be addressed on the next release. Thanks for your patience and understanding.

2 Likes

As ever, we await Vera’s arrival with much anticipation. (Sorry!) :grinning:

Stephen

Thank you very much for addressing this!

1 Like

Hahaha!

betas

1 Like

Thanks it isn’t working for me though. There are one or two things Bluefrog probably knows about already. “Move focus to Inspector” doesn’t work though move focus cmmnd option cntrl v does work.

“Move focus to Inspector” doesn’t work

Hmm… I’m not seeing an issue here.
What OS are you seeing this on?

I use a work round which is control + tab now which cycles round the panes I need.

Just FYI the expand all groups shortcut pete31 suggested doesn’t work for me either and I have the same issue as sawxray with ‘workspaces’ which I use a lot.
I haven’t fully checked the behaviors on open and close the app. It is open nearly all the time with me now.
I am on Monterey 12.0.1 on a 16 inch intel 2019 MacBook Pro.

Does using the left or right arrow key while holding the option modifier not work? It works over here.

1 Like

Sorry it does for child files. I created one to test it. I really want the behavior to open or close all groups at the top level. I don’t tend to nest groups. I tried that shortcut at the database level so to speak but it didn’t do anything.

What happens if you

  • CMD + A to select all
  • OPT + left arrow

? This should collapse everything.

1 Like

That works.
Is that how it used to? If I remember I didn’t used to have to select all like that?

However that works for what I need, which is usually to close anything I have open before moving on as it were, so I can see where I am on the database. Thanks for your help. I might try some more child files and nest one layer deeper.

Not sure but I think in DEVONthink 2 there was a menu item with shortcut for expanding/collapsing.

But normally DEVONthink should remember each group‘s state, I think. In at least one of my databases it doesn’t remember the state anymore and I too would like to know what to do.

1 Like

Yeah to get back to @sawxray 's point as you say. Some databases in some circumstances don’t remember their previous state and, it seems to me, go back to an earlier state, though I am not sure about that. It is quite hard to track really. Useful digression for me though and @BLUEFROG has picked up another obscure issue for me.
I have had one or two things that seem very specific to my own machine I have to say. I am always aware of user error and having shortcuts set up in other places that create conflict. I did try to check this one carefully though. One still misses things.

There is a condition where groups in the item list are showing in an unexpected expanded or collapsed state when reselecting a group in the Navigate sidebar. This should be addressed in the next release.

And yes, there used to be a menu command for Expand All and Collapse All in DEVONthink 2. However, this became problematic in cases where a person may have thousands of groups and documents, even stalling DEVONthink 2 as it tried to resolve all those files in the item list.

2 Likes

Thanks again for squaring this circle @BLUEFROG we did digress and it all takes some untangling with this powerful app. My expanded or closed groups aren’t holding when I close and open, or even when I use workspaces.
again FYI the 'Move focus to…" in the “Go” menu works for everything except ⌘ -⌥ - ⌃ - I

Thanks for the explanation of why ‘expand all’ was dropped, that helps a lot and makes total sense. I am approaching this one with a new nested groups strategy at ‘user level’ as it were. Thanks to @pete31 for pointing the way too. I am going to use more nesting, there is no problem with doing that given my heavy use of search to get to stuff.

My pleasure. :slight_smile:

1 Like