Strange tag behaviour when database transferred

I have a 12GB database that performs as it always has on my iMac when adding documents to the Inbox (both database and global). However, when I transfer that database to my MacBook Pro it has started behaving strangely when adding documents.

What normally happens is that I add documents to my database Inbox. This can be via my ScanSnap, Sorter, ‘Save PDF in DEVONthink Pro’ or directly. From there I file them appropriately.

On my iMac it continues to behave as it always has in that the document is received into the Inbox and I then file it into the appropriate Group without any tags being created or added to the document.

That is how it used to work on my MacBook Pro. However, over the last few days when documents are received into the Inbox a tag called Inbox is also created and added to it. How do I stop it?

Some further information that might help:

I’m using DEVONthink Pro Office.

The database is identical when testing on both the iMac and MacBook Pro.

The database was copied between machines complete by dragging and dropping it.

I’ve tried replacing my MacBook Pro preference files with copies of those from my iMac.

I’ve tried deleting the preference files and letting DEVONthink create new ones.

I’ve deleted and recreated the global Inbox.

I’ve completely uninstalled and reinstalled DEVONthink.

I’ve created a new test database.

No matter what I do, including various combinations of the above, the database works OK on my iMac but has the tag problem on my MacBook Pro.

Suggestions please…

If you’re using the local inbox of a database, then please check via the Info panel whether the inbox is excluded from tagging (it should be) and whether it has any tags.

If you’re using the global inbox, please check whether deleting ((only if the global inbox is empty) the folder ~/Library/Application Support/DEVONthink Pro 2/Inbox and/or the database ~/Library/Application Support/DEVONthink Pro 2/Inbox.dtBase2 will fix the problem.

The local Inbox is excluded from tagging (the box is ticked and greyed out so it can’t be changed) and it does not have any tags.

I’ve already tried deleting Inbox and Inbox.dtBase2 to no avail but tried again to confirm that it makes no difference. It doesn’t.

I’ve created a test Group and dragged a document straight into it. It also gets tagged with the Inbox tag (which is created if it doesn’t already exist). I then tried the same with an existing Group and that is the same so it would appear that any document being added receives the Inbox tag regardless of where it is.

I should also have said in my original post:

I’m running Mac OS X.6.3 and DEVONthink Pro Office 2.0.2 on both machines

Verify & Repair reports no errors found.

Rebuild Database does not solve the problem.

Does this happen on both machines, using the same document? Maybe the document is tagged via OpenMeta. You could check this using e.g. the tool TagIt (

This gets stranger…

No, it was only happening on my MacBook Pro and yes, it was using the same three documents (dragged from emails on the respective machine ie. they weren’t transferred between machines).

Tagit does indeed show the file I’ve been playing with this morning is already tagged Inbox so I deleted it and dragged a fresh copy from the same email. DEVONthink accepted it without assigning/creating the Inbox tag so I dragged fresh copies of the other two documents from their emails. DEVONthink also accepted them OK. I have no idea how they might have got tagged prior to being added to my DEVONthink database but it would appear that they had.

Anyway, as one final test I restored my database to how it was this morning before I started with all my tests, dragged further fresh copies of the three documents from their emails and they worked.

So, having done nothing apart from repeat what I’d already done numerous times already everything seems to be working OK again so I’m at a loss as to what the problem was and what cured it. If it reoccurs I’ll come back to you but in the meantime while it’s not broken there’s nothing to fix. :slight_smile:

Thanks for your help Christian.