Strikethrough isn't saved

Hello, I created two notes in DTTG on my iPad, a Formatted Note and a Rich Text note. I editing both of them and used the Strikethrough on the editing bar, which worked while I was editing. Once I clicked done, the strikethrough disappeared - happened on both notes.

Is this a known issue? Am I doing something wrong?


It is known and and issue has been filed. Thanks!

Thanks for letting me know!

Hello - Loving my move from Evernote to DEVONthink, and wanted to see if the fix for this would be “soon” or is considered a lower priority? I know you may not want to comment on this, but figured it was worth checking up on it anyway.


Glad you’re liking the transition. I can’t comment on the priority (and “soon” is a very relative term). However, we have changes in text editing we are discussing right now.

Just to circle back on this issue… I opened up a rich text file that I had create on my Mac with bold and italic fonts in DTTG. Once I clicked Edit, it removed ALL the formatting. I’m guessing this is part of the same issue, but thought I’d put that in here…

It actually doesn’t remove the formatting. It appears to. Deselect and reselct the file and you’ll see.
Filing an issue.

Any updates on this issue? I try to read the iOS release notes each update to see if this is in there, but haven’t seen it pop up yet (but may have missed one)

This will be solved when the switch to a new rich text editor. On the list for after some other very important updates this year.

I’ve been searching/reading articles (DTTG) on markdown/formatted/RTF notes as well as testing each of these formats with my own notes (latest version of DTTG, 2018-11 and DTPO).

I’m not finding these formats as complete as I’d like (okay, some of my notes use tables/sheets). With rich text, I see the file as I’d expect to be in DTTG, but can’t edit inside the tables). Markdown and formatted notes present the table’s text, extracted from the table structure, with the table gone. (BTW, the tables are very basic - two or there columns and less than 6 rows.). Note: the files are originally created in DTPO using it for formatted/rich text or some MD external editor (Ulysses in my case).

You indicate that a new rich text editor is on the horizon. What I’d like your opinion on is this; Assuming my “documents” make use of the usual formatting (bold, italics, etc) with possibly some simple tables (containing plain text, no formatting or pics included - in fact no pics anywhere), which file format should I use now with the expectation that DDTG will at one point be able to display and allow editing for the file format you might suggest?

I almost always advocate Markdown, as it’s incredibly easy to learn to compose. Even basic styling is easy enoug to learn IMHO.

What do you mean by this?

If a 2x2 table has the following data (excuse the attempt to present table in this text window - e.g. the vertical lines “|” should form vertical edges)

| one. | two. |
| three. | four. |

The RTF file on DTTG looks just as it should.
The Formatted Note (an html file) and markdown look like:


I should add that in DTPO, the RTF and Formatted files look correct, the MD file loses the table appearance.

CORRECTION: forget what I said about MD files, such files do not have tables. It’s RTF (displays correctly but can’t be edited) vs Devon’s formatted notes (don’t display correctly in DDTG).

I’m not sure if this is supposed to be illustrative or part of the table.

This is a simple Markdown formatted table with basic styling applied.

The beauty of Markdown is it’s just raw data and the CSS is purely cosmetics. I have a hyper custom stylesheet that has been evolving over the past year. It only serves to make things “pretty” to me, but it’s flexible and fun to mess about with too, if one is so inclined.

The ±------+ was just a way to illustrate part of a table on this web page, in my message.

I don’t know what I’m looking at in your Markdown attachment, is it in DTPO? Are both windows two different views at a file in DTPO? If so, I tried copying the same text into a markdown file but didn’t get any nice table. Clearly I’m missing some knowledge. Also, I’d want to avoid using css; tables are so easy to create in RTF.

Doing a search on the web, adding tables in Markdown seems to be (somewhat) black magic. I did find out that Ulysses doesn’t seem to support tables.

I’ll just keep looking around the web to learn more about markdown tables.


Yep again.

If you ‘re using RTF, a stylesheet or styling of some sort would be required if you want divider lines in a table.

Tables are simple creatures and part of the original Markdown spec by Gruber. We use the natural extension, Fletcher Penney’s MultiMarkdown (v5 currently in DT). … ntax-Guide

If you use Data > New > Markdown Text, this produces a table…

<style type="text/css">
table {border-collapse:collapse;}
td {padding: 5px; border: 1px solid black; min-width: 50px;}


Indeed it does, thanks for your help!

I should also point out that in Ulysses, when Jim’s file is opened and then I click on the share and choose HTML for output and preview it, Ulysses does not display a table. It just shows the raw text minus the css code, same as that in the editor.

Experimenting further, if I add basic markdown (like headers) in Ulysses below the “table”, and preview that file (again, in Ulysses) it does display the proper headers, but still doesn’t display a true table.

Fortunately, in DTPO and DTTG, Jim’s file displays properly. I’m not very pleased with Ulysses!

You’re welcome!

I believe Ulysses has its own extension of Markdown. We only support Markdown / Vanilla Markdown.

At this point, I’m wondering what is the purpose of having the “strike through” option available in Devonthink on iOS? If none of the file formats available can reliably display and maintain that formatting, why not just remove it from the app to alleviate the impression that it’s usable? Then when you do have it working, the reappearance of this option will be a “signal” to users that it is now functional.