Stupid question: Finding specific content that contains a full stop

I must be an idiot, but, I’m having trouble figuring out what the right way is to search for content in my DT databases where the specific content is literal text like “0.1”.

What I’m finding is that even when I use quotes (as above), the returned results contain a vast amount of data that has tabs, spaces, or other punctuation between the zero and the one.

For example, files containing:
0 tab 1
0+ 1

(Edit: note it is not literally the word tab, but, when I tried to write less-than, tab, greater-than, it was stripped from my post)

And so on are matched.

According to the Help:

“term1”: Contains the string of words term1 , in exactly this form

Which is why I am searching for “0.1”. I’ve also ensured Fuzzy is not enabled.

I’m sure this is me, somehow, but I’ve become blind to what must be obvious for me to find documents which contain literally a zero, a full stop, and the number one (for this example), and ONLY documents which contain that exact sequence.

I’ve tried using single quotes, as well as doing things like escaping the full stop with a backslash, just in case, but, nothing seems to get me where I am trying to go.


That’s not possible because DEVONthink doesn’t index punctuation.

You could probably

Didn’t test but this should work

This seems related to a known issue of undesired search behavior concerning CJK text. In the process of creating the search index, DT (or maybe a macOS framework used by DT) cuts a text document into searchable “bits” such as words and figures. Sometimes the algorithm makes undesirable cuts, e.g. cutting off “0.1” into two separate digits. The user, unfortunately and disappointingly, has no say in how the software makes the cuts.

While the DT team has not signaled their intention to improve this cutting process, I do hope to see better documentation of spoke process and disclosure of the potential of problematic search behavior. Among other things, the issue related to CJK text should definitely be included in the manual as a warning, since it contradicts with the developers’ claim that the DEVONtechnology kernel is “completely language-independent”.