Sudden loss of ability to sync

I’ve started using Devonthink in August last year. The data has been almost entirely imported from Evernote, but I’ve cleaned up some sections and added to it since. Currently I keep it divided into 5 databases.

For the first three months there were no problems with syncing whatsoever. At the beginning of December I started getting “manifest missing” errors. I found several threads on those here, and tried to apply the remedies suggested in these threads. In the end, because it is a busy period of the year for me, I ended up cleaning and re-syncing the failing databases each time. This would typically fix the problems for a bit, but the databases would all keep failing to sync in turns - about once a week one or another would show the missing manifest error and I’d repeat the process.

3 or 4 days ago though I started to get an entirely new kind of error. Neither my Mac, my iPad or my iPhone can connect iCloud kit storage at all. I keep getting CKError Domain 6 and 7, http status code 503. The option to verify or clean iCloud storage is not available to me at all.

I tried waiting through and reducing the Max. Connections number, to no avail. I do need to fix it quickly and at this point I’d like to just wipe iCloud storage and sync it fresh, but this too seems impossible (Clean Location option is greyed out).

Is there any way to fix it? Am I at Apple’s mercy? Is it some sort of request quota I went over by regularly cleaning and resyncing my databases?

I’d greatly appreciate some guidance.

1 Like

Does access to iCloud e.g. via the Finder still work? Do calendar and address book entries still sync across devices (assuming, that is, that you use that functionality within macOS)? Have you tried logging out of iCloud and/or your Apple ID and logging back in?

Everything outside of Devonthink works. I haven’t tried logging out and back in mostly because of how destructive that can be to my work.

Besides, I had cases where iCloud was messed on one device and I needed to relog… but not just one App on all three devices at the same time.

I feel with you. And I agree, if everything else is working then logging out and back in is less likely to be the solution.

Do you have enough space available on iCloud?

Please disable the automatic/scheduleded sync, otherwise the sync attempts will block these commands. Afterwards they should be available again sooner or later (probably within 1-2 minutes).

1 Like


A screenshot of the error message(s) would be useful. In addition, what kind of sync location do you use?


I fixed your post. Did you verify the sync store?

问题仍然存在,我不太清楚您说的“verify the sync store"是什么意思

In that case cleaning the sync store and uploading the database(s) again is unfortunately necessary. Before cleaning the sync store please ensure that the databases on your Mac are fine (via File > Verify & Repair Database…) and that there are no pending items (by performing a toolbar search for `item:pending).

Having switched the synchronization mode to Manual I’ve managed to single out the database which is causing problems. Interestingly enough it passes the verification correctly, but not only can’t I synchronize it, I cannot clean it either (CKError Domain 7 and 6 again).

The other databases pass the verification and synchronize correctly. I’ll try now to clean the whole CloudKit sync storage.

我已经把整个iCloud的数据全部删除了,现在用的是bonjour sync ,可以在同一局域网内同步电脑和手机,只要一选择iCloud同步就会失败并提示错误,非常崩溃

These (in most cases temporary) iCloud errors are returned by Apple’s servers, unfortunately we cannot fix or work around them on our own. The only alternative is to switch to another sync location.



The legacy option isn’t recommended anymore (or only for already existing sync stores).

I’ve cleaned the whole iCloud sync storage, but unfortunately the CK Errors are still here. Besides iCloud I have O365 subscription with quite large OneDrive. Are there any plans to include OneDrive as a supported Sync Storage location?

There are plans but not anytime soon.

I’ve kept on watching the situations for the last three days and I’m still getting the sync to work only intermittently. Sometimes I’m getting manifest missing errors, but most of the time I’m getting connection related errors. Sometimes everything goes through without errors.

What really perplexes me is I had 3 months run with almost no issues whatsoever, and then suddenly everything stops working. Is it possible there’s a problem with local databases which somehow causes the sync to fail? I sort of rule this out, because databases work correctly and sync via Bonjour without any problems… But I can try Rebuilding them, when I get a free moment, if it’s worth a try…

Another question I have - can this be caused by a system update? I’ve updated my Mac to Monterey 12.1 (build 21C52) shortly after it had become available. Perhaps there are some maintenance procedures (caches to delete etc.) on my local system, which may help syncing with iCloud?

I have multiple other apps syncing via iCloud without any problems, but none is as data-heavy as DevonThink (6.72GB altogether, 3.16GB in the largest database).

The reliability of cloud services varies unfortunately (depending on e.g. the used data center, the network connection or outages & changes on the server side etc.), especially the one of iCloud.

That’s indeed a possibility as the behaviour/reliability of the CloudKit frameworks of Monterey might be different (as it’s not unusual that macOS upgrades have initial glitches).