Sync button greyed out

Hi, I’m finally going to use DTTG and the sync button on my iPhone is greyed out. I do have several items in the iPhone db under the Mobile sync group.

What’s going on and how do I fix this? Nothing in Settings seems to make any difference.

And what’s the little purple arrow up by the battery mean?


(From the note you posted in this thread):

What version of iOS are you running?
Which iPhone do you have?

Another method that should work is to simply restart your iPhone. This should achieve the same thing as the technique I tried to explain in the other thread, but is less confusing and problematic. :slight_smile:

This indicates that the current app (DTTG in your case) is using location information. In our case, we use it to “tag” documents with your current location.

Jon, it’s an iPhone 3G, running iOS 4.2.1

I have restarted the iPhone twice.

I have removed DTTG by unclicking in iTunes, starting iPhone and reinstalling.

I still, no matter what, have a grey sync icon.


Have you synced successfully before or is this your first attempt?

Sometimes the detection for WiFi can be incorrect. I presume that you are able to use WiFi to access websites?

Are you running a firewall on your Mac or your wireless router?

Do you have any other apps that use Bonjour to sync or communicate? If so, do they work correctly?

Hi, answers to your questions.

First attempt.

Yes, I can access websites.

Time Capsule is my router; requires a WPA pw.

I haven’t done anything with Bonjour; not sure it’s installed. I used it on a PC years ago. Is there perhaps some documentation about setting this up that I’m missing? All of the stuff I’ve seen has like 4 simple steps and wallah it’s supposed to work.


What does this mean?

Make sure both your Mac and your device are connected to the same WiFi network.

My Mac’s are connected to my home network via cable modem and Time Capsule; they have no use for wifi per se. My iPhone is connected to AT&T 3G network.

Is there phone support for this product? It’s taking a long time to sift through and get this working.


Your Time Capsule WPA (WiFi Protected Access) home network is a Wi-Fi network, and both your Macs and your iPhone need to be connected to that same network to sync. If your iPhone is not set up to access your home network, you’ll want to join your home network via the iPhone’s Settings app, Wi-Fi tab. Your phone will still use the AT&T 3G network when you are away from the house.

Thank You, Thank You, Thank You!

I would highly suggest editing the text on the wifi quick start to mention joining the iPhone to the home network. I’m a computer vet, but still didn’t connect those dots since this mobile stuff is still pretty new.

Thanks again!


Glad to help!