Sync dialog switching spaces


When DEVONthink Pro Office displays its sync dialog, it switches my display to whichever space the dialog appears on. Is there any way to keep this from happening?

If it matters, I’m running dual displays on the High Sierra 10.13.3 (17D47), MacBook Pro.


You can disable the Activity Monitor. Select DEVONthink’s Help > Documentation > Appendix > Hidden preferences and click the On link under DisableActivityWindow.

Amazing! Thanks for the quick response. I’ve changed the setting (and verified it from the terminal) – I’ll keep an eye on Devonthink’s behavior.

Thanks again,


No problem.

Presumably because the documentation for DT3 is a work in progress, this solution does not work for DT3… Is there another way to access these hidden preferences in DT3? Also, for what it’s worth, can’t the activity window just be pinned to the same space as the main application window so that the annoyance can be avoided of having spaces constantly switching when the Activity Monitor is activated?