sync does not see computer on the network

First of all, this thing looks great!
Problem is dttg doesn’t recognise my laptop on the network so i can’t sync… Tried it with 2 different networks, and still no luck. Any news on this?

Ps. the “troubleshoot” section says i don’t have permission to view, so obviously also not to post, think this post belongs there though… :wink:

Do you have the firewall switched on on your Mac?

As for the Troubleshooting board: Does it work now for you?

I am also having this problem. I turned off my firewall and rebooted everything, yet my wifi network does not appear on DTTG.

I’m 0 for 2 with this problem and the absence of a sync group in the database I want to sync.

Not an auspicious beginning.

I can see the sync group, but DTTG does not see my mac. I have successfully synced my 1Password database. The firewall has an exception to llow incoming connections from Devonthink.

Firewall on my mac is turned off, and there are no other security things running. My mac is alway visible in a wifi network, and for instance “things” syncs properly over wifi. So I’m sure it is not the network itself.

I unchecked my FIREWALL and I’m in business, sync was immediate.

I’ve turned my mac firewall completely off, rebooted and I still do not see the mac but I also don’t even have a sync group so am even worse off

If you do not see the “Sync group” in your Pro desktop product, the functionality that allows DTTG to see your computer will not be enabled. Users who do see the Sync group in the Pro desktop product are sometimes unable to see their computer in DTTG. We are working on both issues; the second issue is related to Bonjour discovery services and appear to be WiFi network related. However, the first issue (not seeing the Sync group at all) is due to an issue with the 2.0.5 Pro release. We are not certain as to the cause of this problem, but we need your help in determining the cause. One possibility is that your permissions are improperly set on the desktop application. This may be the result of using the Migration Assistant in setting up your computer, and also happens when there are several user accounts on the same computer. Regardless, we would ask that you bring up the “Get Info” window on your DT Pro folder and make sure that you (your user account) has both read and write permissions on the folder. If not, click the tiny lock in the lower right corner of the “Get Info” window and make your user account has read/write permissions on the folder (you might enable ‘admin’ read/write access as well). Then, click on the drop down item in the lower middle section of the window and select “apply to enclosed items.” This will ask if you ‘really want to do this’ and click ‘OK.’ Then try again. Please let us know if this solves the problem. This issue is puzzling as it works for most people (and in our own testing) but obviously is an issue for those posting problems on the Forum. A permissions problem would be a reasonable assumption but we need users to try this out and let us know if that is the cause of the issue. Thanks for your assistance and support of our latest product.

Do you mean the folder containing the databases? If so these have the proper permissions on my mac. I do see the sync icon in all my DT databases so that is not the problem. Will try an uninstall & fresh install tomorrow.

There are a number of issues being discussed here. Before I get into those issues, let’s make sure everyone is on the same page:

  1. Please make sure you have the latest copy of DT Pro (v 2.0.5) installed on your Macintosh.
  2. Please make sure you have selected items to sync with your device by placing them in the ‘Sync group’ in DT Pro on your Mac.
  3. Press the sync button in DTTG. You should see your computer listed. Tap on your computer and see if you get the “pairing” dialog.

Now if you are not seeing “Sync group” in DT Pro, sync will not work in any event. If that is your issue, please post as to:

A. Sync groups show up or not
B. Your Mac processor type (PPC, Intel)
C. Your OS version

If you do have ‘Sync group’ in your DT Pro desktop application and selected items to sync, then the next issue to address is if you see your Mac in DTTG. We use Bonjour services to discover computers on the network and it appears that this service is not working correctly for some users. In that case, make sure your Mac’s firewall is turned off (at least while syncing). You can obtain a (free) app titled “MyDevices” that will allow you to see if your iPad can ‘see’ your desktop computer via Bonjour. If not, we will be posting further hints tomorrow as to how you might resolve this issue. Keep in mind that you must be on the -same- WiFi network, and your WiFi router might actually be blocking Bonjour traffic (and unfortunately, we are not going to give out advice as to how to fix your router to allow such traffic, but you may want to contact your vendor’s product support staff). Further, office networks (appear to) routinely shut down Bonjour services, so this might pose an issue as well. The “MyDevices” app will let you know if this is the case.

Lastly, you DO have Sync group in DT Pro, you CAN see your computer on DTTG, and you CAN connect your mobile device to the desktop - but nothing seems to happen. We recommend:

A. make sure your Mac’s firewall is turned off (at least while syncing)
B. shut down other computers on your WiFi network during the sync operation.
C. try syncing only one or two files to make sure the connection is really happening - syncing large files, or large numbers of files, can take a long time.

We are working on a simpler, more robust “one button” approach to syncing that should remove most of the steps currently required in this process. (Also more user-friendly in giving feedback during the sync process). It should also be more resilient to the vagaries of WiFi network setup and failures. Given the effort involved and Apple’s review cycle on iOS app updates, we cannot give out timeframes - but rest assured this is a top priority for us. That said, the problem of “missing sync groups” and at least some of the Bonjour problems will be addressed as soon as we find solutions.

I’m having problems too, but sporadically. I’ve successfully done a couple of syncs, but now (5 min later - no system changes), the DTTG app can’t find my mac. I’ve found that sometimes my mac gets found, sometimes it doesn’t. It’s pretty random.

It seems like the only surefire way to get the two to “see” each other is to kill the airport on the mac, shut down DTTG via the doc, then restart each.

Michael, i do see the sync group in my database, and all firewall stuff is turned off. My mac is a 3 months old i5 unit running 10.6.4. I tried a de-install & fresh install of DT desktop but that didn’t work either.

For what it is worth i tried my old laptop which has a barebones 10.6 installation with nothing on it except a fresh copy of DT pro and DTTG does see that, so at least my problem seems to be macos related…

Ok, today i got it working! Apparently my macbook didn’t have a cumputername under sharing any more. So i went to the sharing preference pane, and gave it a name and voila, it showed up and syncs!

Here is today’s update on the various issues described on this thread:

  1. On your Mac, launch System Preferences, select the “Sharing” icon, and make sure your “Computer Name” is set. You can set it to any name you like, but if it is not set at all, syncing cannot take place (to be addressed in DT Pro 2.0.6).
  2. We are still working on a bug that prevents the syncing plugin from loading on some users machines. We are working to get an update to DT Pro released that will address this problem. Unfortunately, there is no “do it yourself” fix for this issue.
  3. For users who can see Sync groups in DT Pro but cannot otherwise sync, you may try this approach:
    Click on the WiFi menu icon and choose “Create Network”. This will create a local wireless network with the name of your computer. If desired, a password for sharing wirelessly with your computer may be set. As this local network cannot communicate with your wireless network nor with the Internet, it shouldn’t be a security problem. The range of this local network is limited to the range of the Mac’s wireless signal - so the range is probably not as extensive as that of your current WiFi router or base station. You can also set a password for this ‘local network’ to prevent unwanted communication with other computers within that range. Note also that this local network is temporary. It disappears as soon as you set your (Mac’s) connection back to your normal WiFi home/office network.

Our support engineer came up with this approach (thanks, Bill) and it should resolve many of the problems people are experiencing with respect to either not seeing their computer in DTTG or having issues during the syncing process itself.

We are working on a more robust approach to syncing over WiFi that should address most of these issues.

I just tried that, created a new network on my mac. Went in to DTTG on the iPod and now the sync button is greyed out on the iPod and I couldn’t do anything.

So here is what i did: I used the iPod Settings to force to the other wifi net, stopped DTTG, reset the sync settings, reset the database and brought DTTG up again.

I still do not see my mac on the local network.

Edited to add:

Just for kicks I also tried uninstalling DTTG on the iPod, reinstalling via iTunes, resetting it all again and I still do not have my mac showing up on either my regular wifi network nor on the just my machine one created via the create network suggestion above.