Sync issue (webdav)


I’m trying to debug a sync issue.
I sync to a webdav syncstore.

The issue goes quite far and is even more strange, but I do not want to write a complete post about this issue at the time being.
Main point is, that in order to try to solve my sync issues, I set up a (local) webdav instance on one of my Synology diskstations. This syncstore is not reachable when I’m outside my house, so only local.

My question now:
The Log window displays “1 items left to be uploaded.”
How can I find or locate that 1 item?

Thanks for helping out!

Have you searched the forum for this message?

  • Do a toolbar search for item:pending.
    • If none, are found, try emptying the trash in DEVONthink.
    • If any pending files found and you don’t need them, move them to the databases’ Trash and empty the trash.
    • If there are pending files you need, are you indexing content?
      • If so, are you indexing from a mounted volume, e.g., a networked drive or external hard drive?
        • If so, is that volume mounted?

Thanks for your swift reply!
I deleted all items pending, there were a couple.
I think (part of) the problem originated from storing a zipped Samsung TV manual. The zip file contained multiple language files, and probably due to the zip format these could not be easily removed / deleted from the syncstore.
Not 100% sure though.

Will report back after further testing and investigating.

Sounds good.

I can’t seem to get it solved. Yet.
A brief history:
I have a fairly large DB that has been behaving very strange for the last weeks / months.
I sync several machines, and must admit, over the years that it has grown to become at least a bit unwieldy…
The main thing i noticed among about 4 machines, was that a number of items simply would omit to sync to I think, 2 machines.
To clarify: I use a folder / group structure within Devonthink like this:


All groups within the previous level, so:
2022/2022-05/2022-05-31 (I hope you get the idea)

As I use a hosted VPN on which a webdav location is living (and this has been functioning well for the past couple of years), my first idea was that I had run out of diskspace resulting in sync errors.
To exclude this possible error, I moved my syncstore to a local Synology NAS.
But then, there I ran into sync problems too.
It appeared as if e.g. two of my macs sync’ed differently than the other two, so it got real awkward to know what sync’ed properly and what not.

What have I done until now:

  • verify and repair on all computers
  • check file integrity
  • on one machine I even rebuilt the DB
    The next steps I took:
  • close all db’s
  • move the affected db out of it’s normal location on all my machines
  • verified the sizes on all machines (all inconsistant)
  • created a new db in order to be able to consistently collect screenshots, log items etc from the various connected macs

Next I wanted to create a new syncstore in another shared folder on my Synology, but received the message “Invalid encryption key” while I have no encryption in place??

  • NSXMLParserErrorDomain 26
    And the latest issue:
  • 24/05/2023, 11:44:39: DS1_syncstore.dtCloud Broken or not yet complete data structure of database “6DAC7C5A-B817-41DF-B28C-A75656AA5A15”.

I have also done a thorough verification on the remote syncstore.

My idea was, once I have a new reliable sync(store) running, to move back a single version of the DB that i moved away from the databases (and cleaned from the syncstore) then have that sync over and build up from there.

I will be very happy to receive helpfull insights & suggestions.

[ running macOS versions: 2x Monterey, 2x Catalina, 1x High Sierra ]

Also: What would be the best way to search a database for items like
6DAC7C5A-B817-41DF-B28C-A75656AA5A15 ?

For your information:
Other error messages in the log:
24/05/2023, 16:06:41: 2024_syncstore.dtCloud Invalid encryption key.

24/05/2023, 18:41:39: Line 7: Entity ‘nbsp’ not defined
Line 7: Entity ‘nbsp’ not defined
Line 7: Entity ‘nbsp’ not defined
NSXMLParserErrorDomain 26

Thanks for helping out!

This suggests you did not set up a new WebDav server on your own Synology NAS, repoint everything there, and then finally start syncs fresh. Just a hunch from what you say about “moved syncstore”. Moving not how I would have chosen to do it, if that is what you actually did. Not that it is not correct but worth considering I guess. My Synology WebDAV server works well and has done for a long time—long enough I do not recall how to set up. But all described in the DEVONthink documentation.

I did not have time to go through all your details. Sorry.

What would be the best way to search a database for items like
6DAC7C5A-B817-41DF-B28C-A75656AA5A15 ?

This is not something you’re going to find in your database.

24/05/2023, 16:06:41: 2024_syncstore.dtCloud Invalid encryption key.

This is a different issue and one you need to address.

You should be reporting this directly to us in our support ticket system.
Hold the Option key and choose Help > Report bug to start a support ticket.