Sync not working on one of my machines

I set up sync and thought it was working well between my Macbook and Mac Pro using Dropbox. However, I just noticed that my databases on my Macbook are not syncing properly, and haven’t been since February.

Here’s the error I get:

I tried repairing the database but that didn’t help. I still get the same error.

Try rebuilding instead of repairing.

That seems to have helped. Now it gets part way through. A dialog box pops up that says more than 10% of the files on my local machine will be changed. I click okay. Then a box pops up with a conflict. I choose the Dropbox version and click the box for resolving all conflicts that way. Then I see the sync progress bar and it seems to be moving through, with “Retrieving…” at the bottom.

However, part way through an error comes up and it stops. The error is “New Rich Text 2: Error: File Not Found”.

What can I do?

Please try the Sync operation again AFTER following these instructions…

To enable logging, type the following in /Applications/Utilities/ and restart DEVONthink:

defaults write com.devon-technologies.thinkpro2 DTSyncDebug -bool YES
defaults write com.devon-technologies.thinkpro2 DTSyncDebugHigh -bool YES

This will log more detail to your system log, which can be viewed in /Applications/Utilities/

After you’ve attempted the Sync, open Console, type “DEVONthink” in the filter field in the upper right-hand corner, and copy and paste ALL of the window’s contents into a new text document. Start a Support Ticket at our DEVONtechnologies Support Ticket System and attach the document to your reply. Thank you.