Sync not working

Just spent $14.99 to download the app and trying to get it to work on iPad and iPhone. I get the same problem on both - my computer shows up on the sync screen, but when I tap it I get an application error message telling me the application may become unstable if I continue to use it. I have groups in the sync folder on my DTPro database, quit and restarted DTPro several times, but can’t get it to work.


My first post was done while I was at work. I just tried on my home network and it worked first time. I’m guessing that there are some security settings on my work network that are messing with the sync. I do most of my DTPro’ing while at work, so not being able to sync at work would be a real nuisance.

Another update:
I successfully sync’ed with my iPad and iPhone. BUT, my iPad continues to sync OK while my iPhone refuses to sync any more - nothing happens when tap on the computer name on the sync panel.

FWIW I’m on latest Snow Leopard on a 1 month old Macbook Pro, with iPhone 3GS and a wifi iPad.

This is flaky to say the least, and a big let down. I’ve rarely had a problem this basic even with free apps, let alone one that costs $15.

I’d guess a lot of the beta testers are people who volunteered and were happy to try the app but might not necessary have the time or experience for decent QA.

If you can, hook your computer to the network via ethernet and create your own wifi network (Sys Prefs>Sharing>Internet Sharing:Share your connection from Ethernet:To computers using Airport). You’ll see less ‘flakiness’ during sync than at home.

Yup, like SallyB suggested:

Sync better / robust with computer to computer network

This tip probably deserves to be a more easily noticed/referenced sticky thread and/or in the DTTG FAQ instead of buried in the flood of sync and other problem reports.

Some future version of DTTG could also better indicate progress, slowdowns, stalls, interference, packet loss, … by letting the user know with the slightest hint without talking about the above.

No doubt DT<->DTTG synching will eventually improve/mature. :slight_smile:

Sorry - we are working to determine the cause of the issue. Only some users are experiencing this and we have still not reproduced the problem here. I know that is of no comfort to you but rest assured we will get this fixed, and notify you once we have a new release of DT Pro and/or an update of DTTG. We also note that the UI needs to better reflect the status of syncing operations and that will be among the first issues we address (as many people who have sync issues have no idea if the process has even started).

Actually I’d just like to to work once!

I’m one of the folks with no sync group at all.

I’m afraid you’ll need to count me among the group that can’t sync. The app recognizes my mac but doesn’t get past that pop-up window. My firewall is off as well.

This is a major disappointment. I have been a huge fan of DevonThink Pro and it has saved me countless hours of work. It may sound ridiculous, but I waited for the release of the To Go app before I bought my iPad so I could justify the investment. So right now I’m extremely frustrated.

There are a number of issues being discussed here. Before I get into those issues, let’s make sure everyone is on the same page:

  1. Please make sure you have the latest copy of DT Pro (v 2.0.5) installed on your Macintosh.
  2. Please make sure you have selected items to sync with your device by placing them in the ‘Sync group’ in DT Pro on your Mac.
  3. Press the sync button in DTTG. You should see your computer listed. Tap on your computer and see if you get the “pairing” dialog.

Now if you are not seeing “Sync group” in DT Pro, sync will not work in any event. If that is your issue, please post as to:

A. Sync groups show up or not
B. Your Mac processor type (PPC, Intel)
C. Your OS version

If you do have ‘Sync group’ in your DT Pro desktop application and selected items to sync, then the next issue to address is if you see your Mac in DTTG. We use Bonjour services to discover computers on the network and it appears that this service is not working correctly for some users. In that case, make sure your Mac’s firewall is turned off (at least while syncing). You can obtain a (free) app titled “MyDevices” that will allow you to see if your iPad can ‘see’ your desktop computer via Bonjour. If not, we will be posting further hints tomorrow as to how you might resolve this issue. Keep in mind that you must be on the -same- WiFi network, and your WiFi router might actually be blocking Bonjour traffic (and unfortunately, we are not going to give out advice as to how to fix your router to allow such traffic, but you may want to contact your vendor’s product support staff). Further, office networks (appear to) routinely shut down Bonjour services, so this might pose an issue as well. The “MyDevices” app will let you know if this is the case.

Lastly, you DO have Sync group in DT Pro, you CAN see your computer on DTTG, and you CAN connect your mobile device to the desktop - but nothing seems to happen. We recommend:

A. make sure your Mac’s firewall is turned off (at least while syncing)
B. shut down other computers on your WiFi network during the sync operation.
C. try syncing only one or two files to make sure the connection is really happening - syncing large files, or large numbers of files, can take a long time.

We are working on a simpler, more robust “one button” approach to syncing that should remove most of the steps currently required in this process. (Also more user-friendly in giving feedback during the sync process). It should also be more resilient to the vagaries of WiFi network setup and failures. Given the effort involved and Apple’s review cycle on iOS app updates, we cannot give out timeframes - but rest assured this is a top priority for us. That said, the problem of “missing sync groups” and at least some of the Bonjour problems will be addressed as soon as we find solutions.

Hey Mike,

Thanks for chiming in. My question is, why didn’t you do this in the first place? :slight_smile: Cuz the original dev had it otherwise before you took it over and not enough time? I’m just saying, DT (not considering DTTG) has some bad usability decisions that are still there, maybe you guys know about them know, but with you on board, hope you can help shape the DT as well. :slight_smile:

With certain apps, the OS X and iOS versions are aware of each other before sync, perhaps caching known networks, IPs, and not needing to search for each other. Why not negociate an awareness link at startup, sync on startup like OmniFocus, and maybe even push/pull like one has with mail for real time or periodic sync.


Hi Mike,
I have removed all but 2 files from the Sync Group and nothing has changed. The window that asks me to select the computer on my local network remains open and that’s all she wrote.

The only other thing I can think of is I share a wireless network in my apartment complex. If this is a problem I’m not sure how to get around it.


I’m OK with 1 & 2 above, but step 3 is where it stops working for me. I get my computer name showing up, but when I tap on it, either nothing happens, or I get an unstable application message.

My situation was:

  • Had sync group, DTTG saw desktop computer, but sync timed out after entering pairing code

My situation is, after getting a brand new iMac yesterday and installing DTP Office, that syncing worked perfectly on a new test database. That would seem to eliminate router/bonjour issues as a problem. I am about to reload my existing databases into the new computer and we’ll report on whether those sync.

I have Leopard and DT Office Pro v2.0.5 running on my desktop.

Previously I couldn’t see the sync group, but I think my v2.0.5 was via the automatic update.

When I bought the new Macbook Air, I installed v2.0.5 fresh and noticed that the Sync group had appeared when I open up the same database on the new MBA. Not only that, I could even see the computer in DTTG and managed to sync. (WOOHOO!!)

I tried to open up the same database on desktop (the one running Leopard), and the sync group is still not there.

So I installed v2.0.5 fresh on my desktop (the one running Leopard), and since then the Sync group has appeared.

But my DTTG can’t see my desktop. However, when I open the database instead on my MBA (which obviously runs Snow Leopard), it sees my MBA immediately.

Same firewall settings. Same router, wifi network, etc.

Perhaps bonjour works differently under Leopard? Maybe that is why DTTG can’t see and sync databases opened under Leopard?

… all of which begs the following solution: Sync via Dropbox.
I agree that at $15 the app seems overpriced, given such basic functionality issues.

If you are not seeing Sync groups in DT on your desktop, you will not see your computer in DTTG nor will you be able to sync. This is not a Bonjour issue per se, but a plugin loading issue. Can you post your OS version and processor type? We are actively working to figure this out but it is clear some users are simply unable to load the plugin (in DT desktop applications) that ‘starts’ the whole process. We are seeing the most problems with Intel 10.5.8, although some have reported similar problems with 10.6.4 (OS versions). Are any/all of you using VMWare Fusion? We are trying to find a common thread here, but we are not asking anyway to remove software - just something that explains why our plugin is not loading on particular machines (note that some posters have no problems on one machine and complete failure on another).
We are not going to ask users to configure machines just to use DEVONthink and DTTG. We will have a test version early next week for users reporting this problem that will address this problem. Please send an email to cgrunenberg - at - and he will send you a link as soon as possible. Thanks for your patience and support of DT products.

My work machine where I had no luck at all has Fusion loaded, but I had no VMs running while I was attempting a sync with DTTG. My home machine where I had partial success does not have Fusion installed. Obviously they are on different networks - my work network is a SonicWall and my home network is an Airport Extreme Base Station.