Sync Suddenly Broken

Based on the advice of support, in my case I created a new Dropbox sync store, and changed all my machines to sync with that one instead of the old one. That seems to have gotten sync working again for me. It required re-uploading/download my entire database. YMMV.

1 Like

When I had this issue on early May, I went through the trouble of creating a new sync store and got everything working again for my client, but yesterday their largest main database stopped syncing again. The inbox and their smaller databases are still syncing. Not sure what to do at this point. I really don’t want to create a new sync store again just to have this happen over and over.

Quoting your previous post:

I spent all day with one client setting up Dropbox syncing from scratch again, and before I had a chance to visit the other client, their syncing started working again.

That would indicate a problem with Dropbox, not our sync engine.

Also, for issues like this opening a support ticket from the problematic machine is the better option. hold the Option key and select Help > Report Bug.

So … it’s happened again. As before, sync (via Dropbox) has silently stopped working between my two Macs. Exactly the same symptoms: no errors are reported on either Mac. Changes on either database do NOT show up in the other. All settings appear correct, manual syncs dont appear to do anything (nor do they report problems).

So, rather then try to find a work-around, I’m going to try to isolate the problem with additional testing. If anyone at DT is interested in suggestions tests I’m happy to help debug this issue.

Things I have observed so far:
– Sync is broken in both directions; changes in either database do NOT show up in the other.
– No errors have been reported (that I can find) at any time.
– NO changes have been to sync settings, Dropbox account or settings, or anywhere else. Really, I’m certain of that.
– Sync stops working on July 1st, based on dates on the last item I can find that DID sync.

Tests Performed / Observed:
– Only ONE database is affected. The other databases in common to the two Macs are still syncing just fine.
– I added the failing database to my iPad DTTG set of databases to sync. It synced ok, but only up to the point where sync started failing (July 1st). Newer items were not syncing.

This tends to suggest that this is a push problem, but of course I’m no expert.

Comments, suggestions etc are welcome.

Should I open a support ticket on this?


Yes so we can get logs and system info.

Just to say I have had exactly the same problem with DT2 twice now: Dropbox-synced database suddenly stops syncing, with each version stuck in time, but no reported errors with auto or manual sync on any device. The first time I moved everything to a new DB and started from scratch, and it worked for a while but then stopped again. I have just moved to 3b as it doesn’t feel likely to be less reliable in any event, but I really hope that with drtimhill’s help you can squash this bug as the sync is rather critical to my workflows.

I have the Dropbox Sync-stopped-working bug, pretty much identical to what ‘drtimhill’ reported, in both his initial report here and his second instance on July 13. This is all DTPO, I have not moved to DT3 yet.

I have filed Devon bug report #637158 from one of my affected Macs. (Happy to do it from the other 2 Macs if anyone thinks having logs from all 3 macs would help.)

I have 4 databases including Global Inbox, and 3 of those fail to sync, the fourth, called ‘tech’ still syncs fine between all 3 Macs and iPad & iPhone DTTG.

Tim thought it might be a failure to push. That does not seem to be the case for me.

My iPhone shows all the devon sync status in the Dropbox app recent-files list. From the attached screenshot you can see Push data is showing updates to to all the databases, but only the ones to ‘tech’ DB are available on the other Macs/iOS-devices. I have done several tests on the non-syncing databases from different Macs, and the changes always show in Dropbox recent-files list, but never become available within DTPO.

I will try Tim’s delete sync-store and rebuild sometime over this weekend, but I would sure like to find a simpler way.

If the Devon team has any requests to help them debug this, I’m glad to help!


I am having this issue repeatedly too. The log file reports ‘broken or incomplete manifest chain’ (but this is hidden in the debug logs, and not reported to the user). I have support ticket #912643 open on it. Using Dropbox.

One time it was apparently due to a low disk-space situation. But three other times recently, support has not been able to identify the cause.

In all cases, cleaning the location got the sync working again, but this is not a very good solution.

my 2 mac´s are out of sync with icloud since weeks. i had that problem already a year before and it happens if i not open devonthink daily on both devices. it just forgets what to do after a few syncs from osx to ios, and my other osx never get the same updates anymore.

I have had this problem 3 times this year alone. I have been using Dropbox. Has there been any improvements?

Have you opened a support ticket?
Also note iCloud is a process outside our control and can stall (an issue that has been documented outside of use with DEVONthink).

1 Like

We have not changed the sync code regarding Dropbox for a long time.


Might be a sync issue in general and not necessarily a Dropbox one?

I have the same problem, but with Dropbox.

One of my databases has stopped syncing between Mac, iPhone and iPad. The sync store is in Dropbox. Each show different files, the sync says it’s synced recently. I’ve tried to verify and repair the databases, connect and disconnect the sync, creating new files, etc so far but nothing helps. The Global Inbox and another database I tried it works well so far. I even tried to delete the whole database on iPad, then download it back from the sync store, and it still got only the old files out of it.

Another thing I noticed with my MacBook that wasn’t opened in a while is that it synced up to the documents on iPad, but not the later documents made on for instance iMac. There’s also an indexed folder on that MacBook that doesn’t read any updates, such as new files from the indexed folder, though it does write to the indexed folder.

OK, I think I finally got the database somewhat synced, at least it looks the same on each device. What finally triggered the fix was that on iMac DEVONthink 3 I went to Preferences => Sync and with right clicking the database in sync store “Empty Database”, then turned it back on. I’m not sure what it did and it seemed a bit scary to do that, but after that the different devices seemed to start syncing that database. The iMac database had several items in that database that I had created before leaving for Christmas vacations with just iPhone and iPad, and I had no means to fix the sync before I got to the iMac.

As I noted above…

We cannot reproduce any issue at this time (and none of the sync code regarding Dropbox has changed in quite some time) . On one of the problematic machines, hold the Option key and choose Help > Report bug to start a support ticket and we’ll go from there.

As I said on the post that we seemed to send almost synchronously, it finally started to sync all devices after I did “Empty database” in the sync preferences on that one Mac. Then the changes went to all other devices and they generally started to sync again. Before that none of the devices synced. Maybe that gives some clues?

Unfortunately not. If you did a Clean Database (the wording on English systems), the syncing would be expected behavior regardless of the situation.

It is a remedy in this case, but not a diagnosis unfortunately. :slight_smile:

Hmm, yes, I’m using the English DEVONthink and it was “Clean Database” on that one device that seemed to get the sync going on finally. However, I did all kinds of things on different devices (four of them, two Macs, iPhone and iPhone), none of which synced with each other in any way, until I did the “Clean Database” on iMac. Before this I had already tried to “Synchronize All”, “Verify and Repair”, etc on this same iMac. Without knowing more about your sync implementation, perhaps it’s possible the iMac DEVONthink was holding some kind of lock or whatever in the sync store, related to this particular iMac, to create this situation.