Sync Suddenly Broken

DT sync broke suddenly today for no reason I can work out. It’s been fine for +18 months, suddenly today it breaks … badly.

– 2x MacBook Pro, 1x iPad … all with latest versions of OS and DT
– Sync store on Dropbox (500GB subscription, only 20% used)
– 6 databases, varying from 100MB to 7GB in size

This has all been working fine for months. Today sync is broken. I have done NO upgrades to OS or software, nor changes to network etc. Network is fine, dropbox reports no errors and is fine for non-DT functions.

– Selecting File > Synchronize does nothing. No errors are reported. There is nothing in the log window.
– No changes in ANY database on either computer are appearing in any other (or the iPad).
– Attempting to download any document into DTTG on iPad fails. I don’t get an error, when I click “Download” I get the “wait” circle ani, then that disappears and I’m back to a blank page with a “Download” button. the document is NOT downloaded, nor do I get any error.
– Preferences > Sync happily shows updated timestamps for last sync, and I never get any error. I just dont see any changes appearing on any other computer.

– I’ve checked network setup and Dropbox. Both seem totally fine.
– I’ve rebooted all computers, restarted DT. No change.
– Attempted a manual sync from Preferences. No change.

Any ideas? Suggestions anyone?

(comment: There is VERY little info on sync “magic” in the DT docs, which makes trouble-shooting these issues very hard. I’m tempted to remove the sync store and start over, but I’m totally unclear on how to “connect” a local database and a remote one. I dont like working in the dark like this.)



Some more info…

Since both MacBooks are currently in same network, I tried setting up local (Bonjour) sync. While the setup process was confusing (why a password at each end? What does the check-box enable … it says “merge” but which is the source and which the destination?)

With local bonjour sync I COULD get the databases to merge. However, sync is still broken using Dropbox. It SAYS its done the sync, the time+date stamp of last sync updates (in Preferences > Sync), but NO changes show up on either database.

I’m unhappy about this situation. Things break of course form time to time, but DT is failing to sync but not giving me any errors or indications that anything is wrong. This shakes my trust in the product significantly.


Well, I managed to repair things, and for others who have this problem here is what I did:

  1. Deleted DTTG from iPad and iPhone (along with all data)
  2. On each Mac in DT Preferences > Sync, I unchecked the checkbox to sync the database via the broken Dropbox sync store.
  3. After ALL databases on ALL Macs had sync disabled (step 2), I then right-clicked on each database in the Dropbox sync store and chose Clean Database to delete the data from Dropbox. Repeated on all Macs.
  4. I confirmed in Dropbox (on the web) that the Sync store folder was completely empty.
  5. I then DELETED the sync store on all Macs (in Preferences > Sync).
  6. I then created a new Dropbox Sync store on one of the Macs, using a new name (to avoid picking up any old state from the old store).
  7. For each database, I then enabled sync to the (new) Dropbox sync store, and let it do a full upload of all data to the sync store. I did this ONLY on one Mac.
  8. After all databases were synced, I added and synced them on all the other Macs.
  9. Re-installed DTTG in iPad and iPhone and re-synced to the new sync store.

After this complete tear-down and rebuild (which took about 5 hours), careful testing showed that sync was working properly on all Macs.



I’ve checked network setup and Dropbox. Both seem totally fine.

Third-party access to Dropbox’s servers are via a different mechanism than using the Dropbox application.

Sadly, I’m seeing exactly the same symptoms: two computers that consistently report up-to-date sync times but aren’t seeing each others’ new files), and an inability to download new files to DTTG.

Is a complete re-build my only option?

I can’t speak to the OP’s methodology specifically as that was self-initiated. Would it work? Indeed, as it’s going to a baseline start (which I’m not against, in general).
Are you running DEVONthink 2 or 3?

I’m running DEVONthink 2.

I know from past experience that clearing out Dropbox and the iPad and starting over with sync is not a speedy operation for my large database. I’m hoping there’s a simpler alternative.

Here’s one other weird thing I just noticed. On my two macs (both macOS 10.14.4), one is running Pro Office 2.11.3. The other is running Pro Office 2.11.2, but “Check for updates” reports that no newer version was found. On the other hand, this version mismatch has probably been around for several weeks, and the database was correctly syncing as recently as April 29, so possibly this is unrelated.

There should be no issue with 2.11.2, though you can manually download the 2.11.3 from here

In DEVONthink, hold the Option key and choose Help > Report bug to start a support ticket.

Understood, though I did also check the API (I’m a software dev so that presented no problems). My point was to try to narrow down possible culprits, and after the sync re-build it does seem to be the DT sync engine (or the sync store) getting stuck in some intermediate or undefined state.


Thanks for the follow-up. It’s definitely isolated at this point but we’re trying to find any common threads.

One of my clients who is also using Dropbox to sync their DEVONthink databases between 4 Macs reported to me this morning that their syncing suddenly stopped working.

This reminds me of a day back in early August 2018 when 2 different clients of mine both reported syncing issues on the same day. I spent all day with one client setting up Dropbox syncing from scratch again, and before I had a chance to visit the other client, their syncing started working again. There was also talk in the old forums about other people with sync issues that week.

Welcome @emediserv

Currently we don’t have enough data on this, and yes, it certainly could be a sporadic issue. We can’t reproduce it at this time but are investigating based on the info we have.

Not much to add except that sync has suddenly stopped for me too, with similar symptoms. Using Dropbox, three Macs on DT3beta1, and one device on DTTG. Changes on one machine appear to be not propagated to any other machine.

I believe our syncing stopped Thursday 5/2/19 at some point…wasn’t noticed until Monday morning. We use dropbox and have 4 macs…and suggestions on how to fix the syncing? Each user shows that they are syncing but no one can see what the other does.

Welcome @lringle
We cannot reproduce any issue at this time (and none of the sync code regarding Dropbox has changed in quite some time). On one of the problematic machines, hold the Option key and choose Help > Report bug to start a support ticket and we’ll go from there.

This is very strange, but I also have noticed a sync failure in the last few days, with very similar symptoms (possibly identical) to the OP’s. DEVONthink Pro on an iMac claims it’s synchronized, DT on a laptop claims it’s synchronized, and DT on my iPad claims it’s synchronized, yet they are clearly not showing the same content. I’ve been stumped for the past few days. Up to when I noticed the problem, sync had been running flawlessly for me for years… I was about to try “clean database” in the sync preferences, but didn’t know what that did (it’s not documented in the manual), and a search of the forums turned up this thread. Glad/not glad to see maybe I’m not alone with this issue…

Similar issue, only with iCloud and not Dropbox.

DT3 on MacBook Pro - sync - DTTG iOS (iPad Pro)

In the DT3 preferences pane for sync there is a status update on the Global Inbox that says last sync was 5/8/19 although I’ve been using both devices daily since.

I tried deleting all data from DTTG and reinstalling the databases there but this hasn’t fixed the sync issues. Now the status on the Global Inbox is “Not yet synchronized, merge with remote databases” The spinning wheel is spinning continuously even though there are no documents in the Global Inbox for either device.

DT2.11.3 syncs just fine.

My sync from the Mac to iCloud stopped all of the sudden, but from iOS it still worked. Next day it worked again, for no apparent reason. In my case I suspect iCloud is/was the culprit.

In my case I suspect iCloud is/was the culprit.

As would I. It is known and documented that iCloud can stall, and this is not regarding DEVONthink; it is a general thing that can occur. We have no control over that, nor can we even detect it. However, I will say iCloud generally behaves as expected.

Welcome @phoutz
Hold the Option key and choose Help > Report bug to start a support ticket.