Sync with iCloudkit doesn't work for me

Since I switched to iCloud Cloudkit my databases on four different devices have stopped syncing. Because I wasn’t sure if I had done something wrong during the process of switching from iCloud (Legacy) to Cloudkit I decided to start from scratch. I deleted both instances of DTTG 3 on my iPhone and iPad, cleaned Legacy on both my desktop Macs via DT Sync Locations, cleaned any remnants of Devonthink in the iCloud Drive-Manage Storage window in System Preferences and started the upload process of my database to the remote server on my MacBook. But I don’t see any progress. After 6 hours of upload time my Mainbase (4,7 GB) keeps uploading (that’s what it says in the Databases section of the Sync tab) but I wonder if this is really the case. How long would I have to wait until the upload is complete? What might be going wrong? Any suggestions?
My desktop computers are on Catalina, the iMac is from 2020 and the Macbook is from 2012. I am using a VPN service for accessing the internet. No idea if this matters.

Were any issues logged to Window > Log?

No messages there.

And any activity in Window > Activity? Or was the database uploaded according to Preferences > Sync?

Window > Activity is white. The database is being uploaded according to Preferences > Sync.

A screenshot would be great, thanks.


  1. turn off the VPN?
  2. go back to the service you switched from?
  3. If iphone and Macbook both on the same local network. use Bonjour (which will be much faster and surely more reliable than CloudKit.
  4. I don’t think deleting instances of the app on the phone will have any positive impact, so I would suggest you not do that.
  5. Two things going on I think? First the “upload” from the macbook has to complete, then the download to the iPhone has to complete. Both are fresh starts and first-syncs always take a while. 4.7gb certainly isn’t huge, but others are reporting here that Apple appears to be throttling the servers or something. I don’t know more. (Hence my Bonjour suggestion to simply not be forced to debug Apple’s CloudKit now).

Thanks, I’ll try that :slight_smile:

I am trying Bonjour now. On my client (iMac) I keep getting (once every minute) the message “Database busy” in the Log window. Still no apparent sync progress.

My guess is that the database is busy. Sorry, but that’s what the message means.

Any indications of progress on the iPhone? Long press on the “cloud” icon. Or you can see something maybe in Settings/Locations, then pick the local sync using Bonjour.

And to confirm you have only one device (probably the MacBook) with Bonjour “on” with “accept incoming requests”, and have check “on” to synch on both devices databases?

I don’t know much about de-bugging Bonjour as I find as long as the two machines are on the same network and DEVONthink (with the “accept incoming”) is running, it just works for connected devices. I use iPhone, iPad, and Macbook to my iMac which accepts incoming. I see the “busy” message when more than one device is trying to get the same connection and or database.

I am not trying to sync to my iOS devices yet. I want to first see if I can get my two Macs to sync. Do you know what the server Mac is trying to do with the database in question? Is it creating an extra duplicate of the database which is acts as a sync location? In what what other sense could that database be busy?

To know what’s happening under the covers, others here will have to explain if known and/or published by DEVONthink. I don’t know. The DEVONthink Manual has the best descriptions and I hope you have read the Sync bit.

To confirm your setup:

  1. What you want to call the “server” Mac, it has “Accept Incoming Connections” turned ON. You are using the default port 57970 and have a known password. If a different port, take note.
  2. On the other mac, Accept Incoming is NOT turned on. The “server” Mac should be visible in the dialog box setting up sync.

Go through the detailed steps again starting page 61 of the Manual 3.6.2 version to see what you might have missed.

I’m not sure if Firewalls might be a factor, but maybe if you have it turned on on either or both machines, turn off for a moment to check the setup.

Bonjour will not work over VPN. This is coverd in the Help > Documentation > In & Out > Sync > Bonjour section and has been addressed many times on the forums.

How large is the Mainbase you are syncing?

Understood. I have turned it off, the problem still persists.

My database is 4,5 GB. Since I tried switching from iCloud Legacy to CloudKit to Bonjour and back to Legacy sync is in my case completely nonfunctional. Before on Legacy all my 4 devices were synced without problem.

Why did you change the sync method if things were working as expected?

Hold the Option key and choose Help > Report Bug.

I thought it was recommended as a better alternative to Legacy. It worked but I always considered sync slow so I figured why not change to a faster method (as explicitly stated).
By the way, I am unable to close my Mainbase. Is that a default behaviour?

It’s not possible to close databases which are currently synchronized.