Syncing issues with DTTG

I’ve been using Devonthink and DTTGPro for nearly a year. CloudKit sync has been working great. However, starting last week, I’ve experienced serious issues with syncing. I have not changed any settings. I get many errors showing in DTTG and my groups/databases are not synced. This is occurring on iPad and iPhone. Syncing between my iMac and Macbook Pro seem to be fine. Any help would be appreciated.
Jim Ujcik

What errors?

1 Like

Request failed with http status…CKErrorDomain 6

There was another one that I already cleared, appeared to state that each database sync failed in turn. When it pops up again, I’ll post it.

That should be non-fatal and temporary. Wait a bit and check if they’re syncing again.

When you say a bit, how long? I have databases that haven’t synced in 3 days. I’ve restarted DT, and the spinner runs forever, even on databases that were synced and haven’t changed. I’ve also rebooted the iPad. I’ll wait a couple of more days if that’s necessary. I’m really liking DT and this is the first major issue I’ve had.

Check connectivity from the iPad.

I sometimes see that error if two applications are trying to sync at the same time. I use iOS Scrivener and DTTG side by side. So if I (manually) trigger Scrivener’s sync while DTTG is trying to contact the server, I can see this error.

Thanks, while I do have Scrivener on the iPad, it’s not on the iPhone and I’m getting the same errors in both. And I (sadly) haven’t opened Scrivener on the iPad in ages.

This error is continuously coming up, even after shutdown and reboots. Also seems that when a database finally does sync, it takes forever (hours) when it used to only take minutes.

And now I’ve got more info on the errors I’m getting:

an iCould (CloudKit) File xxxxx (lots of numbers and letters) .manifest missing of database xxx.

This message will continue to stack up through the day and the databases are not getting synced.
This has been occurring for about a week now.

Oh, and one other thing I forgot. In the past, while syncing, it seemed that the device would not go to sleep. That is, while adding a new database, or after some changes, it might take a while (quarter hour?) but during that time the device screen stayed on and syncing progress was visible. Now the little circle at the bottom of the database list no longer is showing while syncing and the device sleeps after the normal screen time has been reached.
Again, I appreciate the help. I’ll see if there’s anything else I remember or notice.

In DEVONthink To Go, select Help > Contact Us to start a support ticket. Thanks!

Couple of things.

  1. When I try the “contact us” it takes me to Apple mail. I do not have Apple mail configured on the device. How can I get it to default to my system default (Spark)? Or, is there an alternative to create a support ticket?
  2. I did go through some of the troubleshooting. Interestingly, when I look at “sync” in preferences and right-click on any database, none of them allow me to verify or clean. They are both greyed out. This is on the iMac, which is where the databases were created (I consider it the master, but not sure if that’s the right terminology).

I am seeing the same error since yesterday at DT.

I have been using iCloud sync for a few months. It has been syncing all ok, except sometimes a bit slow. But, I start to the get the CKErrorDomain 6 since yesterday at DT.

In order to isolate the problem, I stop the Sync at DTTG. Just want to make sure that DT can sync successfully to iCloud first. I also change the Sync to Every 15 minutes to prevent the countless repeated tries.

But I am still having the errors.

HTTP 503 is typically a server issue and temporary (sometimes just a few seconds, sometimes for hours).

Indeed, it is gone after getting the errors for two days.

My devices are still not syncing and I’m unable to create a support ticket. Not sure what the next steps are.

Go here to start a support ticket.

I have the exact same problems. Everything worked like a charm for … years. Now all of a sudden the exact same issue as described here. Checked all databases. Checked again. Reinstalled on iOS. Always the same issues. No issues at all when using Bonjour.

Above thread suggests Apple’s servers. any way to check with them?

Is it possible that this is caused by low free space on iCould? I did notice that I’m up to 75% of my 200 Gb. Just wondering…

1 Like

Have plenty of space left. Something went awry somehow at some point. Then iCloud tends to hang on to those issues and they tend to not only mit go away but cause further issues in my experience.

So I deleted the entire iCloud cache linked to DTP and rebuilt the sync stores step by step. Works well again so far. I still get those CKErrorDomain 6 issue once in a while.

1 Like