Tag filter when used on the results of a Smart Group produces odd results

I was searching in the Smart Group “Recently Added” for an item with a particular tag. I typed the tag details into the tag filter box and selected the required tag. Return then clears the display of items, and produces multiple instances of the selected tag in the tag filter box. This is repeatable with different smart groups and different tags. Is this expected?

I noticed this too.
In my case it happens when typing a tag and then pressing enter. It doesn’t happen when clicking a tag from the filter list in the left corner.

Are the tags from multiple databases? Then this is currently correct.

I have the same set of tags for all databases, so that’s why it suddenly adds all those tags. Filtering a group in one database instead of a smart group spanning all databases only results in 1 tag after pressing enter.
Since the documents only contain the tag once, it might be nice to have a feature of additive tags in that filter row (instead of exclusive). I remember that Keep It has that feature, filter by all tags or by any.

The same tags exist in a number of databases. The tag I am searching for is definitely attached to an item in the recently added smart group.I was hoping to filter the list of recently added items by application of the tag in the tag filter box. Initially I thought that the tag filter box did not work at all, until I realised that this behaviour only occurs if using the tag filter box on a smart group.

There is no issue if I select tags , singular or multiple, from the Tag Cloud. The behaviour only occurs when I type the tags into the tag filter box.

Thank you, the next release will fix this.

DT 3.8.5

Not sure if the bug I’m looking at is different or the same.

When I “tag filter” on a smart group by typing in the top tag filter bar, I get zero results. When I pick that same tag out of the tag cloud, I get the results I expect. 100% repeatable.

I can even click on the tag cloud, it populates the tag filter bar and shows results, and if I cut and paste exactly what worked there, I get no results.

The smart group is only searching one database.

Hmm… I’m not seeing an issue here.
Is this a local or global smart group you’re referring to?

Global (meaning on the sidebar under “smart groups”, right?). But it’s still a problem if that smart group is set to focus on one database.

However, I created an identical smart group in a database, and it didn’t have the same bug. Worked as expected.


I duplicated the original, buggy global smart group, made no changes. The new smart group worked as expected for a minute. But now it also has the same problem.


@cgrunenberg: I am seeing the reported behavior in the Today global smart group.

Thanks for the bug report, the next release will fix this.