Tags reappear even if I manually delete it?

For some reason, the PDFs that I’ve imported recently keep having two tags (I tried excluding them from classification to no avail) reappearing.

I delete the two tags and add my own tags but they keep reappearing.

I’ve tried deleting the two tags without adding new tags but the two tags reappear.

What’s happening?

Are they gray?

Are you nesting Tags?

Nope. They’re blue. And they’re normal, non-nested tags. When I drag a new PDF file inside DEVONthink, the two tags apply themselves automatically to the new PDF, for no reason.

And then I try to remove or change the tags but they’re still there. :confused:

Are these Mavericks tags? Check this by selecting a document in Finder and look at File > Get Info. It’s possible that some process is adding Mavericks tags to documents, which will show up in DEVONthink as DEVONthink tags when you import the document.

Nope. I don’t use tags in Mavericks (not a fan – I prefer having tags in DEVONthink instead).

I’ve dragged the PDF outside, deleted the tags (the tags ‘translate’ into Mavericks tags when moved outside into Finder). No tags.

Dragged the PDF back into DEVONthink, the two tags appeared again.

Tried to delete the two tags, but they kept reappearing. :confused:

Is it just in that one database that these zombie tags appear?
Have you run Verify & Repair on the strange database?

I’ve run a ‘Verify & Repair’ and there appears to be no issues, aside from a single orphaned document.

It’s very odd.

I suspect it’s in only one database, as I don’t use tags for my other databases.

Found 0 inconsistencies, 0 incorrect checksums, 0 missing and 1 orphaned files.

Repaired that, no errors found. :confused:

It’s, uh, even odder, because when I browse the Tags list and look in the list of files with the corresponding tag, the files with the ‘zombie’(?) tags don’t appear at all.

Very, very odd.

When you say you’re “deleting the Tags”, how are you doing it?

Sorry, to clarify what I mean:

If I remove the ghost(?) tags from the PDF files in DEVONthink (Inspector, press ‘delete’/‘backspace’ for the tags in the tag window), they reappear again.

But if I look in the total Tags list, and click the ghost tag (there are some legitimate files that I’ve tagged with the ghost tag, but there have been other files where the tag applies itself automatically and refuses to be deleted), the files with the ghost tags are not there.

So, you see the tags in Show Info. You see the tags in the Tags bar. You don’t see the documents in the Tags group for that tag. What color are the tags? Blue or gray? Do you see the tags in View as Tags? Do you see the tags when you export the document (in Finder Get Info)? If you select one of these PDFs with zombie tags and look in Show Info – are there any duplicates or replicants listed at the bottom of the Show Info panel?

How about making a screen shot of the Show Info panel and Tag bar for one of these PDFs? It’s getting difficult to visualize exactly what’s happening here.

And I’m confused because you talked about dragging PDFs our and back in.

If you delete the Tags in the Info pane in DEVONthink, do they spontaneously reappear immediately? Or do they reappear after they’ve been dragged back in?

They spontaneously reappear immediately.

But I’ve found the source of the disease and fixed the problem.

Turns out that the entire folder had the two tags inside (not sure why, as I don’t tend to tag folders. Must have been an accident late at night). I’ve removed the two offending ghost(?) tags from the folder/‘grouped items’ and now everything’s sorted.


Is there any way where I can filter the files that are have no tags?

Looks like I’ve got a lot of tagging to do.

This works.