"Take rich note" and "Take plain note" not working

Has anyone else had problems with the contextual menu items “Take rich note” and “Take plain note”?

Two years ago, I reported that the contextual menu items “Take rich note” and “Take plain note” were not working for me. Devon Tech. and I could not find a solution. Because I clip items frequently and the clipping bookmarklet does not do what I need, I tried to fix the problem again today.

Symptoms: When I select one of the contextual menu items, DT Personal is opened (if it was not open), the originating application stops responding for ten of fifteen seconds, but no note is created in DT. If DT Personal is already open, nothing visible happens, but the originating application stops responding for ten of fifteen seconds.

I got the commands to work briefly today, and was very happy about it, but then they stopped working again.

I don’t know what got them to work. Everything that I can remember trying I have tried again (disabling all login items, making myself administrator of the computer, disconnecting all external devices), but I cannot get them to work again.

Two years ago, they worked when I logged in as someone else. Earlier today, I think they worked when I booted in safe mode. So there seems to be something in my own log-in that causes the problem. But what? I have disabled everything that I can think of.

Something seems to have changed either in Safari’s Reader function or in the Safari extension Custom Reader II, and it has complicated my workflow, so I really want to get the DT contextual menu items working again.

I’d be very grateful for any ideas on how to get these commands working again.

Thanks in advance.


All current software on a two-year-old iMac with lots of memory and storage space

Contextual menu options are contextual, in this case requiring selection of text and/or image content. (But images cannot be captured as plain text.)

In DEVONthink Pro Office 2.8 those contextual menu items appear under the Services submenu when an area of a Web page is selected.

In Safari (and DEVONagent and DEVONthink’s browser) the keyboard shortcut for capture of a selected area as plain text is Command-(, and for capture of a selected area as rich text is Command-).

These captures have always worked here. The delay in response you mentioned may indicate a low memory issue. What is the size of your database, as shown in the total word count of File > Database Properties? Does a restart of the computer make them functional again?

Thanks for the quick response, Bill.

I’m familiar with how the services are supposed to work. Used to use them all the time until they stopped working for me.

The database is 181 MB. I have 16 GB of RAM.

Re-starts have no effect.

Can you think of any other potential causes of the problem? I am determined to fix it.

The most important measure of database size (concerning memory use) is the total number of words (as displayed in Database Properties), not the file size.

Have you used Tools > Verify & Repair to check for errors, or tried Tools > Rebuild Database?

Sorry, Bill, I did not read carefully enough.

Word count is a little less than five million.

“Verify” found 995 inconsistencies. I repaired and rebuilt. Now “Verify” says there are two missing files, but no other errors.

The problem remains.

Please start a Support ticket.

Missing files still shown by Verify & Repair after running Rebuild Database?

Yes, two missing files after verify & repair and re-build.

I have opened a ticket.


There are probably multiple instances of DEVONthink installed on the computer. Please check e.g. the trash, your backups and the folder ~/Library/Application Support.

There were two version in my Applications folder. I discovered the extra one last evening and deleted it. I have searched everywhere else, including ~/Library/Application Support. I cannot find any more instances.

I also upgraded from 2.7.x to 2.8 of DT Personal last evening. I was not aware that I was not running the current version.

The problem remains.

You could Command-click on both instances in the Dock to figure out where the applications are located.

There is only one DevonTHINK icon in the dock.

I am confident that only one instance remains on my hard drive.

Could you please launch Apple’s Activity Monitor application (see Applications > Utilities), choose DEVONthink in the list of processes (while the originating application isn’t responding), click the “Sample” button in the toolbar and send us the result? A screenshot of the list of processes (after entering “devon” without quotes in the toolbar search field of the Activity Monitor) might be useful too. Thanks in advance!

I have uploaded the screen shot.

I have not been able to upload the sample because txt and pdf files are rejected. Which format do you want?

Thanks for your help!

Zip files should be accepted by the forum. But there’s an Automator workflow visible on the screenshot, did you launch it or is it launched after using Take Plain/Rich Note?

Problem solved! Beautiful! Good work! Thank you!!

Two years ago, I created an Automator application called “DEVONthink” to open DT Personal in the background. It was getting invoked by the contextual menu items “Take rich note” and “Take plain note”.

Why I did not find the Automator application when I searched for instances of DEVONthink, I don’t know. Maybe I overlooked it in the results list because of the different icon.

It’s really nice to have these functions working again.

You may close the ticket.