The "Copy Section Link" in Markdown doesn't work

I tried to copy section link in my Markdown document’s " Table of contents", but nothing happened. No links were copied to Clipboard. Is this a bug or I did something wrong ?

  • What version of macOS are you running?
  • Does this persist after quitting and relaunching DEVONthink?
  • Big Sur.
  • Yes.

Have you tried pasting into a new rich text document?

Yes, but to no avail. I check my clipboard and found there were nothing copied.
And there’s another strange thing: After press the “copy section link”, I have to select another Markdown document and select back. Or the “Copy Section Link” won’t show up when right click on the inspector.

That’s very unusual.
Does this persist after rebooting the machine?

Yes. It persist after rebooting.

Drag the Markdown file to your Desktop, compress it, and post it for me.

If it’s private or you’d rather not share it publicly, hold the Option key and choose Help > Report bug to start a support ticket and attach the ZIP file.

Ah… The problem might be the section name.
I tried type some section in English and the “Copy Section Link” works fine.
Buggy when the section name is in Chinese.


I confirmed the issue here.

@cgrunenberg: It looks like an issue with non-Latin characters as Hangul and Kanji (Hiragana, Katakana) don’t work either.


# 안녕하세요
한국사람 너무 좋아.
1 Like

And wait for your next update. :slight_smile:

You’re welcome :slight_smile:

The next maintenance release will fix this.