This request requires an authenticated account. CKErrorDomain 9

This request requires an authenticated account. CKErrorDomain 9.

This is rather vague. To what does “This” refer. I had 5 databases open. Now Im down to one. So it probably has to do with that database. But still don’t now what “this” is. Checked the passwords on the sync settings. The only authentication I can think of. They are OK and now?
CKErrorDomain 9 gives no hits on the site. So it is not info :-). Info is when you get information. Or can I not find the place where the error reports are listed. Like I said. Using the search field on the site gives no hits. I see the error spaced 3,4,5,6, seconds. Then a minute nothing etc. 4 tries for 4 connections I would guess. That is the general setting for sync. So it has to do with sync. Probably apple? But what is “this”??? I’m not syncing large volumes.
Looking for information and what to do about it?

That’s just the error returned by CloudKit. Is DEVONthink enabled in System Preferences > Apple ID > iCloud > iCloud Drive?

Thnx. So DT uses the iCloud connection and does not login itself. The password is just for encryption so I could have thought of that :flushed:. Now I understand. I’m having troubles with macOS. Talking to the level 2 or 3 engineers at apple. The proces adds 15 to 20 second to opening a file, any file from any app. So it makes my second hand pro work like a core2duo. Opening a database via the menu in DT3 is an absolute disaster because of this. I used that as an example. Clicking on a database file happily opens that file within 3 seconds. It does not trigger the xpc… The thing is, it could be connected to iCloud so the support engineers from apple asked me to logout from iCloud. Which was ok with me until now. I don’t use it. But it bites DT3. So I do use it. Unknowingly.

off-topic => Would prefer sync via one drive, more space, cheaper and you get office which I have to use. Dropbox is not an option.I already have enough monthly payments. iCloud is kludge. Everything is synced. No filelevel access (webdav) slow, low on bandwidth. Even my internet connection in upload is to fast for apples taste. :upside_down_face: (A sparse image on one drive. Or is that to risky? Just curious. To be honest. I tried onedrive by mounting it as a webdav and tricking dt into believing it was local. It worked for some time. Then syncing became a problem. As told before. So no surprise. In the end the local sync via webdav to a NAS is the most reliable sync. But opening up the NAS to internet? Even with radius based vpn? Hmmm, I’m weary.)

Do you use lots of Finder tags (see Finder > Preferences > Tags)? Does removing the Inbox from the Finder’s sidebar fix this?

So that is DT3 inbox? Did not know that. Threw it away. No difference. Still xpc peaking at 135% and the 15 second beach ball.
I don’t use tags outside DT. I use tags inside devothink which go to the finder. Before reinstalling my machine I noticed that the directory in Library where the tags are stored was 50gigabyte (Total Library was 100gigs). Which is a lot of metadata. But than again, I have a total of 7TB data directly connected to my Mac and my DT databases added together amount to 1Tb. So that is a lot of tagging (99,99% automatic). Library now is 36gig and I did not write down were the tag info was stored. So I will have to search again.

But there are 1000’s of tags on my system. (Every mail adres or name becomes a tag in DT so go figure. Searching goes fast :slight_smile: And when connected to the file the tags move between databases. So I selected add tags to finder tags in preferences. )

And I have recent tags in finder switched of because it is nog useful. Tags are not useful in finder anyway. Much to sloooooooooooooooooow.

Come to think of it. Were was I looking at. Metadata is stored with the file. So what was that directory with a name related to tagging I was looking at?

Found it. The Metadata directory. It is 5 gigs now. 10% of what is was. 4.6G of that is for DT3.

That’s most likely causing the issue as doesn’t like too many Finder tags.

DEVONthink stores its tags inside the database (and exports them to the Finder), the folder ~/Library/Metadata/com.devon-technologies.think3 contains the Spotlight index of the databases.

Finally, there’s a hidden preference to disable exporting of Finder tags, see appendix of help.

Thnx again. Switched of copy tags from DT3 to finder.
Test. Delete 1 tag in finder. And yes it stays in DT3 (after restarting DT3 of course). Would expect that, but verifying assumptions is always good.
That leaves the other problem. How to get rid of the tags in finder. All 15153 of them. Maybe the software I used to get that number also can fix this. I would hope so.

Theoretically that’s possible via Finder > Preferences > Tags, selecting all tags and deleting them.

Nope. Tried that before I wrote the previous mail. You can only select one tag at a time.
What I is need is “select all tags with an @ or tags with a count less than 5”. Than delete all those tags and they disappear. The moment the count is 0 the tag disappears from the finder list. May via the CLI. Will see. But thnx for also looking for a solution.

I don’t want to loose all the tags.Tags attached to images should stay. A puzzle.

An AppleScript could execute a shell script which removes the Finder tags like this:

set thePath to "/path/to/file"
do shell script "xattr -d " & quoted form of thePath

Rebuilding of the Spotlight index of all databases, if enabled, would be also necessary (see File > Database Properties…)

1 Like

For the curious. I deleted all tags from all files. After deleting the first batch of 15153 another 12367 were found by the software I used. Besides DT3 I have 3 other software packages which tag. Two of them no longer used but useful now for deleting all the tags. After deleting de tags, and reindexing the databases, all set to no spotlight index now I was still left with empty tags not deletable through the finder settings. Which became responsive. So I ran the xattr command recursive from root using sudo. That did the trick.
And another thing when deleting the tags I saw negative counters. The last time I saw those was in the 2nd half of the eighties when you got above MaxInt (RatFor). So the apple tag-software implementation thinks to small number wise? Anyway my system now works like it should be. No more peaks in xpc open and savepanelservice. No more 15-20 seconds wait on opening a file,

So instead of tagging files I should tag groups in DT3 and switch on inherit from group? That way I now the file-tags are software generated? I really would like a mark on each generated tag. This one is generated. A lot of the generated tags are not useful, But deleting them is not helping. So mark as reject would be nice.So an attribute for a tag. A treshold setting would also be nice. If software feels the need to generate tags. Don’t if the count is below 10, 15 or 20. I had 1000’s of tags whith an occurrence of less than 10. 80% or so. That’s not useful for humans. If it is useful for the computer I don’t want te see it.

Thanks for setting me on the right track.

1 Like

You could still tag files in DEVONthink like in the past but you should probably enable the hidden preference DisableFinderTags

Done that. But I want to make a difference between the tags I come up with and the autogenerated tags. If I exclude groups from tagging, that is auto-tagging. I can still tag a group manually. With inheritance I get what I want. I was thinking. Or is that somehow flawed? Well, I’m gonna find out

This is an example of the autogenerated tags have no use for.