Thousands of documents in Trash

Something very strange has happened to my database and I’m not sure how to fix it. For some reason, thousands of my documents have been placed in the Trash. And what’s more, their Location in the info pane says they are not in the Trash but in their actual position in the database. The problem is that if I delete the file from the Trash, it is also deleted from the database (from the location that shown)!

I think this might have happened when I turned off the “Exclude Groups from Tagging” option in my database and deleted a few tags that contained large groups. But I’m not sure.

Please tell me there is a simple fix for this?

Please start a Support Ticket.

So, this seems to be normal behavior - could someone confirm?

When you remove a document from a Tag group by clicking delete key (backspace) this document retains its place in the database as expected, but some kind of alias is also placed in the Trash. If you look at the Location (in info pane) of the document in the Trash, it points to the original location in the database and not the Trash.

If you empty the Trash with the usual Empty Trash command, everything works as expected. The alias is removed from the Trash, but the document retains its place (and tags) in the database. But if you try to delete the alias in the Trash by clicking delete it has the same consequences as if you would have deleted the original document in its Group in the database - its location is changed to Trash, removing it from the database.

Seems to me this is a pretty unintuitive and risky behavior. My case was this:

  1. Had done a lot of rearranging of tags, deleting documents from tags with the delete key (as I normally do).
  2. Noticed that the Trash contained 10.000 files and that I probably should empty it.
  3. Tried the Empty Trash command but because of the large amount of big documents my computer ran out of application memory and I had to force quit Devonthink.
  4. Figured I’d have to chunk it down but found no command for selective emptying of the Trash (is there one?).
  5. Next inuitive step for me was to select documents in the Trash and delete them through the delete key.

Luckily I first tried this with just a couple of documents, and not thousands, noticing that they were deleted from the database instead of the Trash --> figured I was lucky that the Empty Trash had failed.

Did you contact Support as requested?

Thanks but no need. it kind of solved itself after I discovered this.