Translate has never worked

Pretty simple problem - I visit an international site like and DEVONagent shows a German flag in the upper right corner. I click it, it beeps and grays out. The page is still in German.

I’d really like to be able to use DA’s built-in translation feature, but it’s never worked for me. Any ideas why?

As long as the region of your system isn’t set to German/Germany (see System Preferences > Language & Text > Formats), you should be able to translate the page. The used localization doesn’t matter right now.

My region is set to “United States”. Translate doesn’t work on any language, whether it’s German, Italian, French, etc.

I don’t have any language packs installed. Could that be it? I thought it just used google translate under the hood though.

You can of course use other Web-based translators. I’ve got Babelfish bookmarked and open it when I need to do a translation (German, French, Italian, Spanish, English) - which frequently happens for support queries.

In case you’re interested in a beta checking the region/language settings (maybe there is no setting at all?), please send me an email. Thanks.

I’m having the same problem unfortunately. I’ve tried re-setting my Language system preferences (to UK); but no joy…

I’m using OSX 10.6.4 and the latest versions of DTPRO and DA

the beta fixed this problem for me, so you should send Christian an email