Typing and Cutting & Pasting In Two Languages

I create and cut and paste text in two languages (US English and Italian). However it is very annoying to have everything in my secondary language (Italian) underlined in red. Is there a way to avoid this, i.e., spell check can work in two languages at the same time?
Mac OS 11.7.1 in DevonThink 3
Hope someone can help me out. Thanks!

Not exactly sure what you are doing…

If you create a new file via Data > New > Rich Text (or Plain Text…), then cut text from another file in DT or from an other application and paste it into the new file in DT, the spell checker should be able to detect multiple languages simultaneously. Just be sure that “Automatic by Language” is enabled in Edit > Spelling and Grammar > Show Spelling and Grammar.

1 Like

I went into System Prefs and then Keyboard, and then Text. I selected only the languages I use (four) and deselected the others. I then restarted the laptop and, yes, DT3 does detect both English and Italian without the annoying red underling. And it will also detect spelling errors in both languages. I don’t know what originally happened, but everything is working great now. THANK YOU for the response! I really appreciate it.