Ulysses Snippets, Exports not Showing in DTTG 3

In testing I’ve found that if I attempt to send a markdown document from Ulysses to DTTG3 on my iPad Pro (Share, tap on DTTG3 icon) when it arrives in DTTG3 it is an “unknown” document type and will not preview or open. When DTTG3 syncs it to DTP3 on my Mac, it shows as a .ulyz file, previews and opens normally (see attachment).

If I export from Ulysses to DTTG3, DTTG3 shows it as a zip archive and won’t preview or open. The same when it syncs to my iMac.

If I export from Ulysses as plain text, it shows in DTTG3 as plain text, and previews and edits. Ditto for the sync to my iMac.

Maybe a problem with DTTG3 with accepting markdown files??

Here’s the screenshot I forgot to include …

Maybe Ulysses shares a .ulyzas that is what, obviously, arrives in DEVONthink To Go and is correctly shared to DEVONthink on the Mac. It looks as if documents in Ulysses are not pure Markdown files but packages containing, probably, the Markdown document and supporting files like images.

Indeed, Ulysses does proprietary things with its Markdown and file format.

.ulyz is Ulysses’ proprietary format that contains additional files such as images.

On iPad, in Ulysses, do not use Share but try exporting as Markdown and then selecting DTTG as the share target. Works for me normally with DTTG 3.

Thank you! I tried using the export button to export as Markdown instead of the share button and that worked. So obviously the issue is not some oddity with Ulysses using some proprietary format, but rather with the process you use to capture the document to DTTG3.

Glad that it worked!

So just to clarify, the problem is not on Devonthink’s end:

  • When you export as Markdown, as you have now, Ulysses will export a more or less pure Markdown file, which both DT and DTTG will properly recognize and render as Markdown, but…

  • When you use the share sheet to share from Ulysses, Ulysses will export in their proprietary format, .ulyz. Only Ulysses can then open this.

The reason DT on Mac will properly render files exported as .ulyz and why you are able to see these on desktop is that Ulysses on desktop registers itself to handle and preview Ulysses sheets (.ulyz files) so that works inside DT just as you are able to preview any other file on Mac elsewhere because the original app handles that. On iOS there is no such thing so DTTG cannot handle that file on its own which is why it does not show any preview or anything.

2 Likes

Very helpful, thank you.

Sharing from Ulysses gives a file in Ulysses format. Export from Ulysses shares a Markdown file. Please feel free to let the Ulysses people know that this was unexpected for you.