Unable to make a PDF: No Content

Hi all,

I’m just starting to really use DTTG and am confused on saving a web page as PDF. Viewing the page https://qvault.io/golang/how-to-use-golangs-generics, I select the share sheet, DEVONthink and the save as a PDF. I see the article in my inbox

but it frustratingly has no content!

It also does not sync back to my Mac, presumably because it is an empty document. What might I be doing wrong?

That clip works for me in DTTG (both as PDF and as PDF clutter free); it would seem from the screenshot that the document does actually have some content (see text below the title in the list view). I would suggest restarting your device and seeing whether the problem persists.

(iOS 15.2, DTTG 3.2.4; I am using various blockers though; it is possible I am blocking some content from the site which is causing trouble)

1 Like

Did you try this again?

I am not seeing an issue capturing that URL as a PDF.

How to Use Golang’s Generics.pdf (330.5 KB)

@Blanc your suggestion worked; restarting my device worked. Thanks!

It was odd how the short summary displayed, yet the document was declared empty…

1 Like

Some pages aren’t processed correctly (separate from this issue that apparently was resolved by restarting your device). Another work around is:

  • open a webpage
  • take a screenshot (device dependent, press two appropriate buttons)
  • press the thumbnail
  • select ‘Full Page’
  • share with DTTG

In fact I’ve setup a shortcut that I share to, that saves these into an appropriate group, depended on a selection I make in a menu. Or I take the ‘lazy’ road, use the clipper and process the file afterwards.

These steps also work in Mail by the way (might you want to save a PDF of an e-mail for example)