Unable to name or rename imprinters. All called "New Imprinter."

Whenever I create a new imprinter now, its name is “New Imprinter”; and I cannot seem to change it.

I was able to do it previously, but I do not remember how.

Press the Return key.

Wow. I feel stupid.
Thanks, Blue.

No worries at all and you’re very welcome :slight_smile:

If it makes you feel any better, despite being an excellent speller (and not-so-excellent typist - lol ) I on rare occasion stop and think this when spelling the word of,… “‘of’? ‘uv’? Wait…what?” :stuck_out_tongue:

Can custom stamps with images still not be used in imprinter settings? Is there any other way to make a ‘watermark’ with images? Thank you

Sorry but no, this is still not supported and no, there is no current workaround within DEVONthink.

Thank you very much for your kind response; regards

You’re welcome :slight_smile:

I’m curious what kind of image-based imprint you’d like to make. Do you have an example?

Sure. For example, an ink approval stamp

Can you post a screen capture of that?


Do you actually need such an ornate imprint?

If originals are PDFs, perhaps use a PDF editor product that can do this. Probably Adobe Acrobat and I notice PDFPen can insert images.

1 Like

Off-topic (but you opened the door, Bluefrog): Outside of competitive spelling-bee circles, the mark of an excellent speller is knowing if and when you need to check yourself. As I’ve gotten older, I find that even some very common, very familiar words sometimes appear strange on the screen as I type, so much so that I usually do a quick check. When wrong spellings no longer look strange is when you need to worry.


If there is still a need to add watermarks to a pdf, Apple Preview will do that.