Unable to open a Database and rainbow wheel

I dragged a group (about 20K text files, so less than 2 Gb) from a database (about 36Gb) to another one, when the rainbow wheel appeared, freezing DT and not going on even after many minutes.

So I made a force quit.
Now I’m not able to open the Database where the original files are stored: the rainbow wheel appears and DT freezes and doesn’t respond, even after many minutes.
The bar of the Opening Database stays still, empty and doesn’t go on.

I also copied and pasted the Database to another location and tried to open it as a new one, but nothing.

I also tried to recover an old version from TimeMachine, but it keeps saying I haven’t enough disk space (but the Database is 36Gb, and I have 96Gb of free space), so I’m not able to recover it.

The Database is synced via iCloud Kit.

I can open all the other Databases without any problem.

How do I fix it?

I have your support ticket.

Related to disk space, Finder is a liar, because it “estimates” and does not count the local stored disk snapshots as used space. You can use a third party “clean” tool to remove those (the “system” space), or you can use the Disk Utility, enable view local snapshots and manually delete them. I’m not near a Mac just now, but the option to show the snapshots should be in the View menu.

Theoretically, macOS should do that “automagically” when someone requests more space, but as any other zillion things, it does not always work.