Unable to print latest PDF+Text after DevonThink OCR conversion

Hello all,

I hope you are well!

I am experiencing a strange issue with my Devonthink 3 setup:
When I scan a new document to my DT3 Inbox it is received as a JPEG file. When I print the JPEG at this stage it come out of my printer just fine as expected. After applying the DT3 conversion to a PDF+Text every try to print the resulting PDF+Text file will result in a blank page coming out of my printer!?!
Because of this issue I am not able to retrieve any printed copy of any of my lately generated DT3 PDF+Text documents which is a nightmare for me! I am really relying on this functionality.

Here is what I have done / tested so far:

  • I have not changed my workflow and what I am doing has been working just fine for the last years
  • rather old PDF+Text documents generated with DT OCR conversion print out just fine (e. g. from 2010)
  • I am using the latest DevonThink Pro Edition 3.5.2
  • I updated to the latest Canon MF8050Cn printer driver version 10.11.4
  • the print preview dialog from macOS looks always normal (shows print content - not blank page)
  • I tried to print from another Mac PDF application like Preview or PDF Expert with the same faulty result (blank page)
  • other document formats like email (.eml), Pages (.pages) or images like e.g. *.JPEG do print without an issue
  • converting my scanned JPEG document to only a PDF (without Text / OCR) also results in a proper print out

My other setup parameters:

  • macOS 10.15.7
  • MacBook Pro (15 Zoll, 2019)
  • CPU: 2,3 GHz 8-Core Intel Core i9
  • RAM: 16 GB 2400 MHz DDR4

At this stage of my above described testing I have the suspicion that the DT3 OCR process is causing the print out issue for me.

Can you please help me to restore the proper print out functionality for PDF+Text documents generated by DT3.

Thank you and best regards

I haven’t been able to reproduce the issue here, can you provide a copy of the PDF+text file and the original jpeg file possible.

Hi aedwards,

please find the two requested examples attached.

Test PDF+Text.pdf (264.3 KB)

Printing the PDF works here…

I also can print the PDF without issue to an HP OfficeJet 0910.

Okay. Sounds like the DT OCR conversion might not cause the issue. I still cannot print the PDF+Text, though.

And even more confusing is the fact, that older PDFs which were also run through the DT OCR conversion are printing just fine. Also PDF+Text files which are not coming from the DT OCR conversion do print okay. So no general printer or PDF issue in my setup, I would conclude.

I still can only limit the problem to newer PDF+Text files which have been created using the DT OCR conversion here on my end. Those are the only files which print blank pages.

No idea anybody?


I noticed the PDF spec for FRE12 is 1.5 and there’s no explicit MediaBox, TrimBox, or CropBox. There is just a BBox.

FRE11 was PDF 1.3 and has those structures from what I’ve seen.

1 Like

The ABBYY OCR determines which version of the PDF spec the output file uses dependant of what features are required. A 1.5 spec file will contain a MediaBox and the provided file does contain this and the values are valid.

I have exported your PDF file to a PDF in Preview which will generate a PDF 1.3 spec file. Does this file print?
TestPDF1a.pdf (304.5 KB)

@aedwards @BLUEFROG
I just tested the printing to another (Samsung) printer which I attached to the very same system config as mentioned above. And as with your print tests mentioned above this printer does print the PDF+Text just fine.

So it seems to be the combination of the newly created PDF+Text files from DT with my Canon printer… :frowning:

No. This also only produces a blank page on my Canon printer.

If you open the PDF file in Preview, select File->Print and select “Open in Preview” option from the PDF combo in the bottom left corner. After pressing the print button do you get a blank page in preview? The generated page uses the same mechanism as printing to generate the file.

Following your steps I do not have to push the print button since selecting “Open in Preview” does this right away for me. But the result looks fine. It displays the full PDF in Preview.

@BLUEFROG @aedwards
I did another test: I installed the latest Adobe Acrobat Reader DC (which I really DO NOT want to use honestly) and printing the PDF+Text to my Canon printer does work that way.

Still not working from Apples Preview or Readdles PDF Expert, though.

So does Adobe do something different when printing PDF+Text files than DT, Preview or PDF Expert?

Adobe created the PDF specification and Acrobat can do many things other PDF applications can’t.

Yes, of course. I am aware of that fact.

Unfortunately the situation stays unsatisfactory for me:
As long as I have an alternate printer available, I have to remember to (only) print certain PDF+Text files to that one while others can go to my main printer.
Alternatively I have to remember to (only) open certain PDF+Text files with Adobe Acrobat Reader when I want to print them. All other documents are printable without any problem straight from DEVONthink.

That really does mess up my workflow which has been working for years until now.

I would compress and send the file to Canon’s support and see if they can reproduce the issue or have any insight into it.

Yes, good idea. Since other printers (HP, Samsung) do not seem to have a problem with the PDF+Text document.

I will do that.

And if they have some insight into the issue, please feel free to share the findings here… if you’d like. :slight_smile: